Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using TeXShop on OS X Lion (the MacTeX distro, which is kind of amazing) and I cannot do the following with siunitx:

\SI{4}{\giga\byte}

TeXShop says it's an "Undefined control sequence." According to the manual I should be able to do this:

\usepackage[detect-weight=true, binary-units=true]{siunitx}

or this:

\usepackage{siunitx}
\sisetup{ detect-weight=true, binary-units=true }

but that's not working, and I've tried small variants.

How can I make the "byte" unit work?

share|improve this question
3  
I was able to solve this by doing the following: \usepackage[detect-weight=true, load-configurations=binary]{siunitx} I did that instead of my existing siunitx usepackage statement. I don't know if this will be useful to anybody else, it required a little digging on my part, so maybe someone else won't have to do that digging now. Sorry to put this as a comment - I don't have enough rep to post an answer to my own question so soon. –  finity Nov 30 '11 at 3:14
1  
What version of siunitx do you have? To find out, add \listfiles before \documentclass and view the .log file. –  Werner Nov 30 '11 at 3:37
    
I tried what you had in your question (not in your comment) and everything worked fine. Whatever the problem, I don't think it is texshop's doing. –  Frédéric Nov 30 '11 at 3:37
    
This looks like the classic 'Not checking the documentation for the package version you have installed' issue. Picking up option names from an internet search without checking on what you have installed is always a risk. I'd suggest this is 'too localized'. –  Joseph Wright Nov 30 '11 at 8:52
1  
@JosephWright but maybe someone else tries the same, fails and finds this page here... so maybe you could make your comment an answer, stating that he used invalid options or a wrong version, link to the siunitx documentation and/or post an example of how it would be done correctly. Would help the person, and you can be shure to get at least my upvote –  matth Nov 30 '11 at 9:37
show 1 more comment

1 Answer

up vote 3 down vote accepted

The issue has occurred as you've tried to use an option from a newer version of siunitx than you have installed. Always check the documentation for the version of siunitx you have installed, easiest to do using

texdoc siunitx

at the Command Prompt/Terminal.

(This is a general point: it's true of any package.)

share|improve this answer
    
So, you wrote siunitx? It's very handy. Thanks. –  finity Dec 6 '11 at 19:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.