Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using TeXworks on Windows7. About an hour ago, I was happily working along and compiling documents just fine. Now, suddenly, when I try to compile anything, I get this error:

latexmk.exe: The Perl interpreter could not be found.

I closed the program and started it again, but I still get the error. Does anyone know what happened, or how I can fix it?

share|improve this question

closed as too localized by Peter Grill, egreg, Joseph Wright Nov 30 '11 at 22:15

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Without a crystal ball it is virtually impossible to solve this with the current information. Have you restarted your computer? Did you install or update to a different perl distribution? Have you Googled? –  Werner Nov 30 '11 at 21:26
1  
Are you perhaps using Strawberry Perl? According to this link, Strabwerry Perl is installed in C:\strawberry\perl\bin, and latexmk expects it in C:\perl\bin. So perhaps some auto update feature kicked in and changed things. –  Peter Grill Nov 30 '11 at 21:36
2  
I figured it out!!!! D'OH!! In the dropdown box at the top of the editor, I usually have it set to pdfLaTeX, but I must have accidentally switched it to LaTeXmk. It never occurred to me to look there as I've never used anything but pdfLaTeX, and don't know anything about the other options. Ooops! Thanks for your help. –  Jand Nov 30 '11 at 21:47
1  
@Jand: Write up an explanation of the answer and post it. Self-answers are perfectly admissible, and a well-written answer may earn you additional reputation. –  Werner Nov 30 '11 at 21:57
2  
I think this question is probably 'too localized' really –  Joseph Wright Nov 30 '11 at 22:00
show 2 more comments

Browse other questions tagged or ask your own question.