Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've installed Beamer 3.12 upgrading from 3.07. Now I get an error when running just this basic file below. Tried switching to other versions as well but this error always came up. What I did to update is add the beamer package from bitbucket to ~/texmf/tex/latex/beamer. Even tried putting the git in there and then I ran sudo texhash and texhash ~/texmf.:

 \documentclass[ignorenonframetext,handout]{beamer}
\setbeameroption{show notes}
% \usetheme[invert]{wkbeamer}
% \hypersetup{pdfpagemode={UseNone}} % Forces not to go into fullscreen mode like default in wk
\title{A Neurobiologically Plausible Computational Model of Sound and Speech Recognition}
\date{November 24, 2011}
\begin{document}
\begin{frame}
\maketitle
\end{frame}
\end{document}

It gives me this error:

--- TeX said ---
<inserted text> 
                \par 
l.13 \ProvidesClassRCS
                       $Header$

Then from the log file:

Runaway argument?
Header$ \ProvidesPackage {\beamer@rcsfile }[\beamer@rcsdate \space (r\ETC.
/home/bigtyme/texmf/tex/latex/beamer3.12/base/beamer.cls:13: File ended while s
canning use of \beamer@parseid.
<inserted text> 
                \par 
l.13 \ProvidesClassRCS
                       $Header$
I suspect you have forgotten a `}', causing me
to read past where you wanted me to stop.
I'll try to recover; but if the error is serious,
you'd better type `E' or `X' now and fix your file.

Runaway argument?
Header$ \ProvidesClass {\beamer@rcsfile }[\beamer@rcsdate \space deve\ETC.
/home/bigtyme/texmf/tex/latex/beamer3.12/base/beamer.cls:15: Paragraph ended be
fore \beamer@parseid was complete.
<to be read again> 
                   \par 
l.15 

I suspect you've forgotten a `}', causing me to apply this
control sequence to too much text. How can we recover?
My plan is to forget the whole thing and hope for the best.

(/home/bigtyme/texmf/tex/latex/beamer3.12/base/beamerbasemodes.sty
Runaway argument?
Header$ \ProvidesPackage {\beamer@rcsfile }[\beamer@rcsdate \space (r\ETC.
/home/bigtyme/texmf/tex/latex/beamer3.12/base/beamerbasemodes.sty:12: Paragraph
 ended before \beamer@parseid was complete.
<to be read again> 
                   \par 
l.12 

I suspect you've forgotten a `}', causing me to apply this
control sequence to too much text. How can we recover?
My plan is to forget the whole thing and hope for the best.

\beamer@tempbox=\box26
\beamer@tempcount=\count79
\c@beamerpauses=\count80
(/home/bigtyme/texmf/tex/latex/beamer3.12/base/beamerbasedecode.sty
Runaway argument?
Header$ \ProvidesPackage {\beamer@rcsfile }[\beamer@rcsdate \space (r\ETC.
/home/bigtyme/texmf/tex/latex/beamer3.12/base/beamerbasedecode.sty:12: Paragrap
h ended before \beamer@parseid was complete.
<to be read again> 
                   \par 
l.12 

I suspect you've forgotten a `}', causing me to apply this
control sequence to too much text. How can we recover?
My plan is to forget the whole thing and hope for the best.

\beamer@slideinframe=\count81
\beamer@minimum=\count82
)
share|improve this question
    
Which TeX distribution are you using, and how did you update your beamer file? –  cmhughes Dec 1 '11 at 3:39
    
@cmhughes - added the description to the top of the text. Basically I installed it in my home directory under ~/texmf and then updated texhash ~/texmf as well as sudo texhash. It had no problem finding beamer after this but gives this error. Should I install it in /usr/share.... texmf directory? –  J Spen Dec 1 '11 at 4:37
1  
It's usually best to update using the appropriate tool from your distribution- there are often dependencies that can not be easily predicted. If you're using linux, then it is recommended to use TeXLive 2011 from http://www.tug.org/texlive/ The update tool for TeXLive 2011 is tlmgr –  cmhughes Dec 1 '11 at 4:49
    
@cmhughes - cheers mate just installed the updated version and smooth sailing. Should have thought of that previously. –  J Spen Dec 1 '11 at 6:14
add comment

3 Answers

up vote 8 down vote accepted

This happens when people download beamer directly from the development repository and do net set up Mercurial to replace the keywords in the code. (beamer is set up to use SVN-like keywords.) The release version of beamer on CTAN has the appropriate replacements made, and this version is used by TeX Live and MiKTeX.

share|improve this answer
add comment

As Joseph Wright explains in his answer, this problem appears because you installed beamer from development repository. You have two options, first is to use CTAN version and the second follow Vedran's instructions in Problem with ClassRCS and PackageRCS from beamerbasercs issue. They worked for me.

share|improve this answer
add comment

Here is my original comment posted as an answer:

It's usually best to update packages using the appropriate tool from your distribution- there are often dependencies that can not be easily predicted. If you're using Linux, then it is recommended to use TeXLive 2011 from

http://www.tug.org/texlive/

The update tool for TeXLive 2011 is tlmgr

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.