Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This is a followup question of this one. It uses the same MWE but about a different issue so a separate it here. I used Tikz node to create the custom legend but used absolute positioning to place it where I wanted it to appear (below the plots, in the middle). I always try to use relative positioning when I create my Tikz images, but I don't know how to do it here. Or maybe there is some totally different approach in producing subplots with common legend?

share|improve this question

closed as too localized by Joseph Wright Jan 7 '12 at 21:13

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
There's an example in the PGFplots manual called "Legends Outside Of an Axis" which might do what you want. If it doesn't, could you include an example of what you're trying to do? –  Jake Dec 1 '11 at 12:08
    
I had a similar issue; finally I did a workaround by adding empty plots with the same style to one of the axis, then putting the legend outside the axis. –  gerrit Dec 1 '11 at 16:07
    
Without a full MWE, I think this is 'too localized'. Edit in a MWE then flag and it will be reopened. –  Joseph Wright Jan 7 '12 at 21:14
add comment

Browse other questions tagged or ask your own question.