Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using classicthesis to write my document. I don't use the option drafting but I can see on the bottom of the page the date (there is a part of the date that is not readable, but when I copy and paste this part I obtain [ December 1, 2011 at 20:50 ]). This is my code:

\documentclass[a4paper]{scrreprt}   % classe report di KOMA-Script

\usepackage[english]{babel}     % Per scrivere in inglese
\usepackage[T1]{fontenc}        % Imposta la codifica dei font
\usepackage[utf8]{inputenc}     % Lettere accentate da tastiera
\usepackage{classicthesis-preamble} % Preambolo classicthesis
\usepackage{classicthesis}      % Classicthesis

\begin{document}

\input{Chapters/0_Introduction}
[...]

\end{document}

I would like to avoid this little issue.

I use TeXworks in Windows7 x64.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

The file classicthesis-preamble.sty includes these lines:

\PassOptionsToPackage{eulerchapternumbers,drafting,listings,%linedheaders,%pdfspacing,%listings,
                                            subfig,beramono,eulermath,parts}{classicthesis}

so this package internally passes the drafting option to classicthesis. If you want to avoid this, you can 1) Not load the classicthesis-preamble package or 2) Change the order in which the packages are loaded:

\usepackage{classicthesis}
\usepackage{classicthesis-preamble}

I don't know, however, what side effects could this last option produce.

3) Make a copy of classicthesis-preamble.sty and save it as myclassicthesis-preamble.sty somewhere TeX can find it (your current working directory, for example). Open this file and search for the lines I mentioned above and comment-out (or delete) the drafting option. Save this file, and in your document, instead of

\usepackage{classicthesis-preamble}

use

\usepackage{myclassicthesis-preamble}
share|improve this answer
    
Thanks. I've used the switch solution. –  Baduel Dec 1 '11 at 20:32
    
To resolve the side effect (this warning: Package "classicthesis" should be loaded AFTER "classicthesis-preamble") I have now adopted the 3rd solution. –  Baduel Dec 2 '11 at 9:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.