Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This is my first document with LaTeX and I have this problem: Every time I try to compile I get this error:

! LaTeX Error: File `biblatex-apa.sty' not found.
! ==> Fatal error occurred, no output PDF file produced!

I guess it is due to LaTeX not finding the package biblatex-apa. Is this right? If it is right, I don't know why LaTex can't find it, because I have installed it.

I saw you like to have MWEs for helping so I hope this is what you need:

\documentclass[
    a4paper,
    12pt,
    %twocolumn,
    headings=normal     % big,small
]{scrreprt} %scrartcl,scrbook,scrreprt

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[english,ngerman]{babel}

\usepackage{mathptmx}               
\usepackage[scaled]{helvet}

\usepackage[style=apa, 
        hyperref=true,        
        isbn=false,
        firstinits=true,
]{biblatex}
\usepackage{biblatex-apa}
\bibliography{Data_richtig}    
\usepackage[babel]{csquotes}

\begin{document}

blabla...

\end{document}
share|improve this question
    
Welcome to TeX.sx! A tip: If you indent lines by 4 spaces, they'll be marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). I edited for you and marked the code. Further, I removed thanks and name below the post, it's not usual here, and your name is automatically below your post at the right. –  Stefan Kottwitz Dec 4 '11 at 12:07
4  
From the manual, it seems that you don't have to load the package, just specify the style. So if you remove \usepackage{biblatex-apa}, does it work? –  Torbjørn T. Dec 4 '11 at 12:31

1 Answer 1

You should not load a package. To use the apa style, just specify it in the options for biblatex. Hence, remove \usepackage{biblatex-apa}, and it should work.

From the manual, section 2:

Specify the style in the usual way when loading biblatex.

\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage[style=apa]{biblatex}
\DeclareLanguageMapping{american}{american-apa}

About localisation:

Normal use will invoke babel with the ‘american’ babel language. After loading babel and biblatex, put this in the preamble (see full preamble example in section 2 above):

\DeclareLanguageMapping{american}{american-apa}

[...]

Here is an example to load the German localisation strings. This assumes that you are using the babel package with the appropriate language option:

\DeclareLanguageMapping{german}{german-apa}
share|improve this answer
    
Thank you very much! Yex, it does work now. The trick was, that I removed the hyperref=true, isbn=false, firstinits=true –  Anna Dec 4 '11 at 14:16
    
Thank you very much! Yes, it does work now. The trick was, that I removed the hyperref=true, isbn=false, firstinits=true, I also removed the \usepackage{biblatex-apa} and I added the last line you suggested (\DeclareLanguageMapping{ngerman}{ngerman-apa}. –  Anna Dec 4 '11 at 14:25
    
@Anna: You may also thank Torbjørn T. by upvoting his answer (with the upward pointing arrow to the left of it) and accepting it (by clicking on the checkmark). –  lockstep Dec 4 '11 at 15:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.