Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

On my "List of Tables" page, the descriptions of tables don't wrap. Instead, the text proceeds on the same line all the way to the far-right margin of the page (past the point where the page number of tables is usually set), where it is truncated.

This has worked very well on another report, but something in my styling is different here. I would rather not attempt to create shortened descriptions for the list of tables; this is a fragile solution, broken by any number of general formatting adjustments.

I am using the ociamthesis style file, and invoking a list of tables with:

\documentclass[a4paper,titlepage]{ociamthesis}

...

\begin{document}

...

\begin{romanpages}
\tableofcontents
\listoftables
\listoffigures
\end{romanpages}

What can I change to encourage correct wrapping of the table descriptions?

share|improve this question
    
May you give an example of how you write your captions? –  egreg Dec 4 '11 at 21:11
    
Perhaps the problem could be side stepped by using \caption[Short caption for \listoftables]{Actual caption which sounds like it is quite long} –  cmhughes Dec 4 '11 at 21:37
    
My captions look like: \caption{TLINK classification with and without signal features, using both 10-fold cross validation and a one-third/two-thirds split between evaluation and training data.} I think I have just fixed this, though; I am using the hyperref package but didn't set the [linktocpage] option. Adding that has fixed the lines (found this answer elsewhere on tex.stackexchange) –  Leon Derczynski Dec 4 '11 at 21:40
7  
From the example you have given the problem is not comprehensible. Please add a minimal example that clearly reproduces the problem. But presumably your are loading the hyperref package. If so, add breaklinks to its options. –  Thorsten Donig Dec 4 '11 at 21:43
1  
@ThorstenDonig: you could turn your comment into an answer, so Leon Derczynski can accept it (and upvote it). –  Gonzalo Medina Dec 5 '11 at 0:11

1 Answer 1

up vote 1 down vote accepted

Your example has not enough information to give a clear answer. Presumably you are loading the hyperref package in the preamble of your document. If you really do so, add breaklinks to its option list. As you already mentioned, the linktocpage option would be an alternative.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.