Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I wrote a large part of my thesis with MiKTeX 2.9 using siunitx for all units in the text. Now I did an update of MiKTeX 2.9 and suddenly no document is created any more although no error appears. After a while, I found the MWE:

\documentclass{scrartcl}
\usepackage{siunitx}
\begin{document}
This is my text
\end{document}

Within the MWE-folder, only a .log file is created, but no other files like .aux, etc. As I already mentioned, no errors or warnings are shown. Does anyone have any idea what's going wrong here?

share|improve this question
1  
We are going to need to see a log listing, or at the very least what \listfiles gives. –  Joseph Wright Dec 5 '11 at 19:32
2  
@Anja: Do you use the editor TeXnicCenter. Maybe you need additional packages are loaded by siunitx. This is a bug of TeXnicCenter. Try an other editor like TeXStudio. –  Marco Daniel Dec 5 '11 at 19:33
    
@Anja: Which editor do you use? –  Rainer Dec 5 '11 at 19:45
    
Indeed I am using TeXnicCenter. I just found on the MiKTeX website that this is a known bug, as Marco said. The solution the website suggested worked indeed - I simply changed the MiKTeX option for "install missing packages on the fly" to "yes" rather than "ask me first". Now the MWE is working. Thanks to all of you for your hints! –  Anja Dec 6 '11 at 11:21
    
For future reference: It would have been an obvious choice to include the actual message "GUI framework cannot be initialized" as part of your post in the first place. This comes from examining the .log file. –  Werner Dec 6 '11 at 16:56
add comment

1 Answer

Once again as an answer - the bug with TeXnicCenter is described on the MiKTeX website along with the solution: http://miktex.org/2.9/issues

share|improve this answer
    
But you should be aware, that all on-the-fly packages are installed into the user folder, so that in the future you will have to update always twice: the admin packages and the user packages. Maybe this question is also relevant for you: tex.stackexchange.com/questions/29616/… –  matth Dec 6 '11 at 11:32
    
@matth: Thanks for this note. Indeed I wasn't aware of this, thinking that changing the settings in the Admin mode would mean that on-the-fly packages are installed for all users. –  Anja Dec 6 '11 at 13:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.