Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am despairing trying to solve the following problem. When compiling the following minimal example:

\documentclass{article} 
\usepackage{times}
\usepackage[document]{ucs}
\usepackage[polutonikogreek, english]{babel}
\usepackage[utf8x]{inputenx}
\usepackage[LGR,T1]{fontenc}       % T2A is Cyrillic
\newcommand{\grrk}{\selectlanguage{polutonikogreek}\fontencoding{LGR}}
\newcommand{\ee}{\selectlanguage{english}\fontencoding{T1}}
 \begin{document}
\grrk  ἀφιέναι \ee `to send off, discharge', with infinitive: `suffer, permit'
\end{document}

Running pdflatex, I get the following error:

(C:\Users\rvw\AppData\Roaming\MiKTeX\2.9\tex\latex\unicode\ucsencs.def
fontencoding LGR patched
) (C:\Users\rvw\AppData\Roaming\MiKTeX\2.9\tex\latex\grtimes\lgrptm.fd)Running miktex-makemf.exe...
miktex-makemf: The grtm source file could not be found.
Running hbf2gf.exe...
hbf2gf (CJK ver. 4.8.0)
Couldn't find `grtm.cfg'
miktex-maketfm: No creation rule for font grtm10.
! Font LGR/ptm/m/n/10=grtm10 at 10.0pt not loadable: Metric (TFM) file not foun
d.
<to be read again> 
                   relax 
l.10 \grrk
            ἀφιέναι \ee `to send off, discharge', with infinitive: `...

Everything is all right if I do not include \usepackage{times}.

I understand the problem has to to with my font installation. But I am completely lost trying to understand how to solve it.

I am using MikTeX, all packages updated, on a win7 machine.

share|improve this question
    
Welcome to TeX.sx! You don't have to sign with your name since it automatically appears in the lower right corner of your post. –  Joseph Wright Dec 7 '11 at 10:06
1  
Your example 'works for me' using TeX Live 2011 on Windows: I suspect you may be missing some parts of the required font files. –  Joseph Wright Dec 7 '11 at 10:08
2  
The times package is obsolete. Either use mathptmx or txfonts. –  Thorsten Donig Dec 7 '11 at 10:11
    
Using mathptmx doesn't change anything. Yes, I seem to be missing some part of the font files. But how do I get them? –  Ruprecht von Waldenfels Dec 7 '11 at 10:27
    
Let me clarify my question. Where do I find a short recipe that will enable me to just rebuild my font directory in such a way that it will be complete? –  Ruprecht von Waldenfels Dec 7 '11 at 10:50
show 3 more comments

2 Answers 2

I am no expert on fontencoding and this is too long for a comment, but if you comment out the \ee command it works.

\documentclass{article} 
\usepackage[combine,document]{ucs}
\usepackage[polutonikogreek, english]{babel}
\usepackage[utf8x]{inputenx}
\usepackage[LGR,T1]{fontenc}       % T2A is Cyrillic
%\newcommand{\ee}{\selectlanguage{english}\fontencoding{T1}}
\newcommand{\grrk}{\selectlanguage{polutonikogreek}\fontencoding{LGR}}
 \begin{document}
\grrk  ἀφιέναι 
\end{document}

I have used the combined option of UCS. If you uncomment you will get more meaningful errors, such as \textpsili unavailable in encoding T1.

share|improve this answer
add comment

The code works on TeX Live 2011. It seems that MiKTeX does not have some fonts.

Since you use UTF-8 encoding, I advise you to use XeLaTeX or LuaLaTeX solution. It is more modern and you can use Times New Roman on Windows or Linux Libertine on TeX distributions.

Example:

% XeLaTeX
\documentclass{article} 
\usepackage{fontspec}
\defaultfontfeatures{Ligatures=TeX}
\setmainfont{Times New Roman}
\usepackage{polyglossia} % replacement of babel
\newcommand{\grrk}{\selectlanguage{greek}} % not necessary
\newcommand{\ee}{\selectlanguage{english}} % not necessary
 \begin{document}
\grrk  ἀφιέναι \ee `to send off, discharge', with infinitive: `suffer, permit'
\end{document}
share|improve this answer
    
Thanks a lot, the minimal example worked! In addition, txfonts, which at the beginning did not change anything, now works. This is either because running that example somehow led to the generation of the missing files, or because I did not wait long enough for MikTex to load txfonts before. I cannot at the moment use XeTex or LuaTex because the transliteration of cyrillic I am using will not work with those. In any case, thank you all a lot! –  Ruprecht von Waldenfels Dec 7 '11 at 13:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.