Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm writing thesis using tuned report class, biblatex and biber for bibliography. bib file entries are generated by ScienceDirect export citation feature and style is czech-iso.

For referring to some figure, graph or table I'd like to get this layout:

Image

Caption

From: 1st Author et.al.: Title [#].

and in bibliography

[#] 1st AUTHOR, 2nd AUTHOR, 3rd AUTHOR, Title,...

For that purpose I use

\documentclass[a4paper,11pt%,draft%
 ]{report}
\usepackage[french,english,czech]{babel}
\usepackage[utf8]{inputenc}
\usepackage{url}
\usepackage{float}
\usepackage{lipsum}
\usepackage[
backend=biber,
babel=other,
sortlocale=cs_CZ,
style=iso-numeric,
autocite=superscript
]{biblatex}

\newcommand\foo[1]{\footnotesize{From: \Citeauthor{#1}: \citetitle{#1} \cite{#1}}}
\addbibresource{citace.bib}

\begin{document}
\lipsum[1]
\begin{figure}[H]
image
\caption{Text}
\foo{Yoshizawa:1993}
\end{figure}
\lipsum[2]
\printbibliography

\end{document}

but it returns:

1st AUTHOR, 2nd AUTHOR,... : "Title" [#]

How can I shorten the \citeauthor output without any effect to otput of \printbibliography?

share|improve this question
    
Please add a minimal working example (MWE) that illustrates your problem. –  Thorsten Dec 9 '11 at 9:09
    
Do you mean the option maxcitenames and maxbibnames? –  Marco Daniel Dec 9 '11 at 9:21
    
Thorsten: I thought that my example was minimal enough... –  Crowley Dec 9 '11 at 9:31
    
Marco: I've never heard of them... –  Crowley Dec 9 '11 at 9:31
    
@Crowley: It was too minimal, because it was not working. See my Thorsten's link for more information about MWE and my answer for an example of a MWE. –  Schweinebacke Dec 9 '11 at 9:32

1 Answer 1

up vote 5 down vote accepted

You may set option maxcitenames to only influence the cites but not the bibliography, e.g.,

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@book{ Author:2001,
  author = {1st AUTHOR and 2nd AUTHOR and 3rd AUTHOR},
  title = {Title}
}
\end{filecontents*}

\documentclass{article}
\usepackage[demo]{graphicx}% option demo for demostration only!
\usepackage[maxcitenames=1]{biblatex}
\bibliography{\jobname}

\newcommand\foo[1]{\vspace{3ex}% \\[3ex] replaced to avoid "there's no
                            % line to end here" errors
  \footnotesize{From: \citeauthor{#1}: \citetitle{#1} \cite{#1}}}

\begin{document}
\begin{figure}
 \includegraphics{fig1}
 \caption{Some text}
 \foo{Author:2001}
\end{figure}

\printbibliography
\end{document}
share|improve this answer
1  
With option mincitenames=1 it's foolproof. Thanks for your answer. –  Crowley Dec 9 '11 at 13:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.