Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to typeset a few secret codes and I thought it would be cool to use the code in "The Dancing Men" by Sir Arthur Conan Doyle. Sure enough, someone (Alan Stanier to be precise) created a dancers font in Metafont and it's included in TeXLive 2011 (OS X 10.6.8, using AUCTeX). I tried to use it but the output is all smooshed together. Since I know very little about using fonts in LaTeX I don't know if this is a problem with the font or with my usage of it. I tried

\documentclass{minimal}

\DeclareFontFamily{OT1}{dancers}{}
\DeclareFontShape{OT1}{dancers}{m}{n}{
    <->  gen * dancers
}{}

\begin{document}

\usefont{OT1}{dancers}{m}{n}

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

a b c d e f g h i j k l m n o p q r s t u v w x y z

\end{document}

which produces squished dancers. Also putting \qquad between characters does not create a discernible difference, so I can't even work around it in that way. I also tried deleting the file /Users/gvol/Library/texlive/2011/texmf-var/fonts/pk/ljfour/public/dancers/dancers12.56pk in case I had generated it incorrectly in one of my initial experiments, but it didn't help.

Adding \fontsize{52pt}{14pt}\selectfont after the \usefont gives roughly what I want, but that seems completely wrong and when selecting from the pdf it's far too large (because it's a 52pt font obviously).

What have I done wrong and how do I fix it?

share|improve this question
add comment

1 Answer 1

up vote 4 down vote accepted

You can set

\spaceskip=10pt

to get larger space between words (spaces). In this font, the interword space is 0pt, and 1em (length of \quad) is also 0pt. So the spacing is too small.

You can also set

\fontdimen6\font=20pt

to get a wide \quad.

share|improve this answer
    
I guess it makes sense that the interword space is 0pt since word breaks in the code are indicated by a flag (a capital letter in the font). Your answer allows me enough to work around the problem, but when I remove the spaces between characters they are still too close together. At least I know that it's not something I did incorrectly. –  Ivan Andrus Dec 10 '11 at 20:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.