Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Possible Duplicate:
TeX accents do not seem to work with fontspec and xe/lua/latex

Very frequently I need to write letters with dots below (like ḥ or ṭ) for transliteration. It's ok when the font I'm using comes with the character, but I can't use that character with other fonts.

It used to work with xelatex and xunicode package, I'd just use \d{t}, for example, but that doesn't seem to be the case anymore, it just works if the font has that particular character.

Is there a way to "force" a dot below a letter in any font?

Here is the basic preamble I've been using:

\documentclass{article}
\usepackage{fontspec}
\usepackage{xunicode}
\setmainfont{Minion Pro}

EDIT:

OK, I found the simplest solution myself, I just changed the preamble to (all the rest being equal):

\documentclass{article}
\usepackage{xunicode,xltxtra}

So now I can put that \d{} (dot below) on any character, any font.

I hope this helps people with the same issue.

share|improve this question
add comment

marked as duplicate by egreg, Roelof Spijker, Mico, Gonzalo Medina, Leo Liu Dec 13 '11 at 15:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

You can use the stackrel package to place things above or below text. E.g.:

\documentclass{article}
\usepackage{stackrel}
\begin{document}
    $\stackrel[\textrm{.}]{}{\textrm{k}}$
\end{document}

I have used a period here, but you could probably substitute another character to serve as the dot, such as "˙".

Another option might be to change the font when placing the dot underneath. Look in the character map under "Combining diacritical marks". These are characters which essentially stacked in the same place as any character placed before. You may be able to use one font for the letter, then use another font for the diacritical mark.

share|improve this answer
    
even using \cdot, that places an awful lot of space between the k and its dot... –  wasteofspace Dec 13 '11 at 11:30
    
To make the dot closer, make it into an exponent. Use $\stackrel[^\textrm{.}]{}{\textrm{k}}$. –  Village Dec 13 '11 at 14:21
    
That's still pretty far off. Also, it messes up the vertical spacing. Compare your solution to \d{k} in running text. –  Roelof Spijker Dec 13 '11 at 14:41
add comment
\documentclass{article}
\usepackage{fontspec}
\usepackage{xunicode}
\setmainfont{Minion Pro}
\begin{document}

\Huge \d{o}

\end{document}

enter image description here

voss@shania:~> pdffonts test3.pdf
name                                 type              emb sub uni object ID
------------------------------------ ----------------- --- --- --- ---------
POXWQN+MinionPro-Regular-Identity-H  CID Type 0C       yes yes yes      5  0
share|improve this answer
    
I get Missing character: There is no ọ in font Minion Pro Display/ICU:script=latn;language=DFLT; –  egreg Dec 13 '11 at 12:16
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.