Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using xepersian and XB Niloofar font to produce Farsi documents. When enabling [Kashida] option, although XB Niloofar has the kashida (U+0640) glyph, I get a fuzzy output. Any solution?

\documentclass[12pt]{article}
\usepackage[Kashida]{xepersian}
\settextfont[Scale=1]{XB Niloofar}
\setdigitfont[Scale=1]{XB Niloofar}
\setlatintextfont[Scale=0.9]{Junicode}

\begin{document}
سلام، من هر روز به مدرسه می‌روم. 
بایستی به قدری بنویسم که تراز کردن 
اتفاق بیفتد و از کشیده استفاده شود. 
این کشــــــــیــــــــــده است؟
\end{document}
share|improve this question
    
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. –  adn Dec 14 '11 at 2:59

1 Answer 1

XePersian seems to be inserting a horizontal rule not the kashida glyph regardless of the presence or absence of kashida in the font used (that what I see from the code).

Rules are rendered slightly differently from actual glyphs, which results in the fuzziness you see.

share|improve this answer
    
This option works fine with "Adobe Arabic" or "Scheherazade" fonts. Check here. –  Hedy Dec 14 '11 at 11:52
1  
I'd say the documentation is wrong, or I didn't understand it, since I tested with several fonts including Adobe Arabic and Scheherazade, and a rule is always used. With Adobe Arabic it is even more broken as there are wide gaps around the inserted rule. –  Khaled Hosny Dec 14 '11 at 12:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.