Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I plot a graph with pgfplots sometimes I got such warning message

NOTE: coordinate (500,0) has been dropped because of the y-coordinate filter.

However in may case such points are legal. How can I disable such NOTE messages.

Here is a code example:

\begin{figure}
  \begin{tikzpicture}
  \begin{axis}[xmode=normal,ymode=log]
  \addplot table[x=k,y=Time]{fig_xxx.data};
  \end{axis}
  \end{tikzpicture}
\end{figure}

Thanks.

share|improve this question
add comment

1 Answer

up vote 12 down vote accepted

You can add the following to your preamble (or locally in the axis environment):

\pgfplotsset{filter discard warning=false}

This does exactly what you need. However it also removes warnings for unbounded coordinates.

share|improve this answer
    
Thanks a lot. Indeed this is exactly what I need :) –  jutky Dec 14 '11 at 20:39
    
Where can I find a full reference of \pgfplotsset commands? I want to remove also Package pgfplots Warning: the current plot has no coordinates (left?) messages. –  jutky Dec 15 '11 at 11:28
    
@jutky (remember to use the at<user>, then the user will get notified.) I have not encountered one key which is not in the manual. However they can be hard to find if one has no good search ground. But basically they are all there. –  zeroth Dec 15 '11 at 18:22
    
thanks. (also with at<user> it is more easy to get 15 characters to post a comment :) ) –  jutky Dec 15 '11 at 19:04
1  
@jutky the warning "has no coordinates" cannot be disabled currently. –  Christian Feuersänger Dec 16 '11 at 9:55
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.