Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Using XeLaTeX, loading the hyperref package apparently changes the way in which (reconfigured) widow and orphan penalties work — so they reappear, just as if I had not altered the values for the penalties. So, basically, the pages do not break where I would want them to.

I have noticed that loading the frenchlinks option modifies this behaviour, yet without returning it to the settings I want. And I do not have the faintest idea why it does that, given that my document does not contain any link that will be actually affected by it (i.e. turned into small-caps) – all links are either bibliography entires or old-style figures, both being untouched by the option.

Also, I have tried putting the widow and orphan penalty commands after loading hyperref, without any change.

The code I am using rests on the memoir class, with customisations. I am only putting the significant ones in my example code. Here is what my preamble looks like:

\documentclass[12pt,a4paper,twoside]{memoir}

\widowpenalties=3 4500 2000 150
\clubpenalties=3 4500 2000 150

\usepackage{csquotes}
\usepackage[british,frenchb]{babel}
\usepackage{xspace}
\usepackage{fontspec,xunicode}
\setmainfont[Ligatures={Common},Numbers={OldStyle}, Mapping=tex-text]{Adobe Garamond Pro}
\usepackage{biblatex}

% Here I redefine some lengths, formatting options, and add a few abbreviations

\usepackage{hyperref}

I have tried running my file with LaTeX, and have not been able to spot the problem there – but that might just be luck or failure to find a place where it would happen.

EDIT BY GUO: It seems that hyperref set page size by default, which does not compatible with customized document class leading pagebreak to fail. Set the setpagesize option of hyperref to false would alleviate the problem.

share|improve this question

closed as not a real question by Joseph Wright Jan 7 '12 at 22:43

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
As this stands, we can't realistically answer it: exactly what the input and output are is important. –  Joseph Wright Jan 7 '12 at 22:43
    
It's quite hard to understand the real problem. If it is about different page breaks with or without hyperref, please say so and add a MWE –  egreg Jan 7 '12 at 22:44
    
@egreg Yes it is about page breaks with or without hyperref, but as it stands I feel like it can only be caused by an undue interference from the package (since it really shouldn't cause widows and orphans to pop up) or an incompatibility with something else (since this can only be tested on a fairly large document, a MWE is not in order). So, if I can track down where the problem really comes from, I think it may be more appropriate to contact the package maintainer about it. In the meanwhile, thanks for closing the question (feel free to delete it if needed, too). –  ienissei Jan 8 '12 at 10:06
add comment