TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

latex-dvips-ps2pdf compilation sequence produces a weird result when I change the grid style. The problem does not happen when I compile the same code with xelatex.




With latex-dvips-ps2pdf:

enter image description here

With xelatex:

enter image description here

The latest edit

It seems to me this problem has been fixed by a package or class author silently. I have just tried and the problem disappeared!

share|improve this question
I get a Ghostscript error if I do simpdftex latex test (which is a wrapper for latex+dvips+ps2pdf). The PDF is produced, but the error is /undefined in Blue. – egreg Dec 21 '11 at 0:09
with current TL2012 everything is fine with xelatex and ps2pdf – Herbert Sep 29 '12 at 9:42
@Herbert: Yes. I just tried it. Thanks. – kiss my armpit Sep 29 '12 at 9:45
the grid is done on PS side. If you want it like LaTeXs math mode then suppress the labels on PS side and use \psaxes – Herbert Sep 29 '12 at 9:49
historical reason – Herbert Sep 29 '12 at 9:56
up vote 4 down vote accepted

in some special cases the color definition table is missing in the pdf output. In such cases a

  prologue%%    option for package xcolor

should help. Then the package xcolor wrote the color table into the PS and then PDF file. Such a special case maybe the use of the documentclass standalone which creates a single image which then is included in a document which knows nothing about the color Blue. By the way: Using the prologue option in any case doesn't hurt.

share|improve this answer

(Not really an answer, but too long for a comment)

Running simpdftex latex test, where simpdftex is a wrapper for latex+dvips+ps2pdf, I get a Ghostscript error in the ps2pdf phase:

Error: /undefined in Blue
Operand stack:
Execution stack:

The PDF is produced and doesn't show the numbers.

However, as soon as I change Blue into blue or Blue!100, the error disappears and the numbers are correctly produced.

The same error happens if I change Red!20 into Red or into another named color without a blending specification.

It seems a bug in the dvips driver for PSTricks.

share|improve this answer
In my further investigation, gridlabelcolor is the source of problem. It cannot accept any colors defined in dvipsnames. – kiss my armpit Dec 21 '11 at 3:03
PSTricks has no driver for colors ... – Herbert Sep 29 '12 at 10:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.