Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to make a LaTeX file in Russian. I wrote the following in the preamble:

\usepackage[cp1251]{inputenc} 
\usepackage[T2A]{fontenc} 
\usepackage[russian]{babel} 

However, when I try to make a PDF out of it, I get

"Couldn't find 'larm10.cfg'
miktex-maketfm: No creation rule for font larm1000.

Where am I going wrong?

share|improve this question
1  
It seems you are missing the Cyrillic font package. I suggest you to install the full version of MiKTeX 2.9. I suggest also to load fontenc before inputenc (it's necessary when using utf8, for instance). –  egreg Dec 23 '11 at 21:27
    
Well I had no problems typing Hebrew with utf8... Should I save the .tex file in utf8 encoding? –  Vlad Dec 23 '11 at 21:34
    
It's better, if your editor supports it; but this won't solve the larm1000 problem. –  egreg Dec 23 '11 at 21:35
    
I just thought that if I could write Hebrew on the same machine, it means something. So I should download "The complete MiKTeX system" from miktex.org/2.9/setup ? –  Vlad Dec 23 '11 at 21:38
    
You could also try searching for the relevant packages with MiKTeX's Package Manager: install all that contains "cyrillic" (and also the CM-Super fonts). –  egreg Dec 23 '11 at 21:56
add comment

2 Answers

The following MWE works for me and generates the image below.

\documentclass[12pt]{article}

\usepackage[english,russian]{babel}
\usepackage[T1,T2A]{fontenc}
\usepackage[utf8]{inputenc}

\begin{document}

\section{Здравствуйте}

Здравствуйте! Как у вас дела? Меня зовут Калеб. Как вас зовут?

\end{document}

image of my MWE

Perhaps installing the full MiKTeX 2.9 distribution or TeX Live distribution will solve this issue.

If this does not work or if you simply cannot get it to work with LaTeX, you might want to consider using XeTeX. With XeTeX, you can use any of your system fonts in your document. Consider this MWE and the output it generates below.

%!TEX TS-program = xelatex
%!TEX encoding = UTF-8 Unicode

\documentclass[12pt]{article}

\usepackage{xltxtra} % loads: fixltx2e, metalogo, xunicode, fontspec
\defaultfontfeatures{Mapping=tex-text}
\setmainfont{PT Sans}

\begin{document}

\section{Здравствуйте}

Здравствуйте! Как у вас дела? Меня зовут Калеб. Как вас зовут?

\end{document}

image of MWE with XeTeX

Here I'm using PT Sans. Of course, you then might want to consider using polyglossia instead of babel.

share|improve this answer
    
With the order fontenc, inputenc, babel I don't get the warning Package babel Warning: No input encoding specified for Russian language. That's why I recommend this loading order. –  egreg Dec 23 '11 at 21:53
    
Well testing your first code gives me the same error but with larm12 and font larm 1200. As for XeTeX, that'd be my last option - I'd want to try solving it without it ... Thanks! –  Vlad Dec 23 '11 at 21:54
add comment

You should install at least the following MiKTeX packages:

cmcyr
cyrillic
cm-super

The first provides the Computer Modern Cyrillic fonts, which are required to begin typesetting in Russian. The second contains support files and the third provides the Type1 font files for better rendering and printing. It should be considered to install the full MiKTeX distribution and forget about downloading packages.

It's better also to use the UTF-8 encoding, if your editor supports it (and change editor if it doesn't). A typical file for typesetting in Russian starts as

\documentclass[a4paper]{article}
\usepackage[T2A]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[russian]{babel}

If also English is needed (and the main language is Russian), then

\documentclass[a4paper]{article}
\usepackage[T1,T2A]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english,russian]{babel}

is the better option (with T1 possibly omitted, which is instead necessary for other European languages written in the latin script).

The order fontenc inputenc babel avoids spurious warnings by Babel and makes sure that the correct encodings are chosen.

share|improve this answer
    
Thanks for the reply! I downloaded these 3 packages (and currently downloading full MiKTeX), but still got the same error... :-( –  Vlad Dec 24 '11 at 1:28
    
@Vlad Sorry, but I don't have any machine where I can try. I'll change the question's title to add the distribution, so it can attract experts with MiKTeX. –  egreg Dec 24 '11 at 11:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.