Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to use XDVI (as shipped by TeXLive 2010) in a Linux X11 desktop which is using the Compiz compositing manager. Now, when the DVI file being displayed changes, I have to click on the window to have it update: simply giving focus to the window does not cause XDVI to reload the file because (I guess) Compiz makes it believe that it is always being mapped onscreen.

Is there a way to have XDVI behave more reasonably in my situation?

share|improve this question
    
I generally use evince which updates whenever the file has changed (also I generally compile directly to pdf). Maybe it is possible to configure xdvi so that it watches for file changes? –  Caramdir Oct 8 '10 at 22:45
    
Yes. Just run it with the -watchfile <n> flag, where <n> is the number of seconds to wait between checking for file changes. See man xdvi for more details. –  Willie Wong Oct 9 '10 at 0:12
1  
@Willie: You should add that as an answer. –  Caramdir Oct 9 '10 at 4:08
add comment

1 Answer

up vote 2 down vote accepted

Run xdvi with the -watchfile <n> flag, where <n> is the number of seconds to wait between checking for file changes. See man xdvi for more details and more options.

To make it permanent, you can also set the appropriate option in ~/.xdvirc on your linux box. See the manpage again for the correct syntax.


Of course, this only works if the problem was on the xdvi side, and not on the Compiz side; if Compiz does not redraw the window in the situation, whatever you do to xdvi won't help.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.