Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

How do I set the trim correctly? In my case it was wrong on some pages.

\documentclass[a4paper,showtrims]{memoir}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[brazil]{babel}
\usepackage[paperwidth=18cm,paperheight=24cm]{geometry}
\usepackage{hyperref,lipsum}
\hypersetup{pdfpagelayout=TwoPageLeft}

% Trim options
\trimFrame  
\settrimmedsize{24cm}{18cm}{*} 
\settrims{0cm}{0cm}

\title{Memoir with Trim}
\author{R\'egis}
\date{\the\year}
%*******************************************************
\begin{document}

\begin{titlingpage}
  \maketitle
\end{titlingpage}

\tableofcontents

\chapter{Memoir with Trim}

\section{First section}

\lipsum

\chapter{Second Chapter}

\lipsum

\end{document}

Its is my result, wrong. enter image description here

share|improve this question
    
It seems like you want a page size of 18cm x 24cm, right? Where do you want the trim lines to be? –  Werner Dec 24 '11 at 23:02
    
Note that the red line, is going over the text. That's not what I want. I want to crop the page normally, with no overlapping text. –  Regis da Silva Dec 24 '11 at 23:26
    
of course it does not work, you cannot mix memoir layout settings with geometry layout settings. memoir use some special settings to handle page setup. These are normalized by \checkandfixthelayout but they are not set by the geometry package. Solution, use the memoir macros to set the layout –  daleif Dec 27 '11 at 9:52

1 Answer 1

up vote 4 down vote accepted

Is this what you want?

\documentclass[a4paper,showtrims]{memoir}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[brazil]{babel}
%\usepackage[paperheight=24cm,paperwidth=18cm]{geometry}
\usepackage{hyperref,lipsum}
\hypersetup{pdfpagelayout=TwoPageLeft}
\settypeblocksize{16.2cm}{*}{.75}

% Trim options
\trimFrame  
\settrimmedsize{24cm}{*}{.75}
\settrims{0cm}{0cm}


\title{Memoir with Trim}
\author{R\'egis}
\date{\the\year}
%*******************************************************
\begin{document}

\begin{titlingpage}
  \maketitle
\end{titlingpage}

\tableofcontents

\chapter{Memoir with Trim}

\section{First section}

\lipsum

\chapter{Second Chapter}

\lipsum

\end{document}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.