Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Is it possible to use the \ell character from the default font when using MinionPro? If so, how? The documentation actually mentions \ell on page 20; the letter is supposed to be taken from MinionPro, I suspect that \ell is not part of the fonts I took from Acrobat Reader to install MinionPro. This example

\documentclass[11pt,a4paper,oneside]{book}
\usepackage{minionpro}
\begin{document}
$\ell$
\end{document}

only produces a crossed out box for me. Maybe with some LaTeX skill it is possible to use something like

\DeclareMathSymbol{\ell} {\mathord}{letters}{’140}

to take the \ell from Computermodern.

Edit: Could someone try to reproduce this problem?

share|improve this question
    
I can reproduce it. –  ptomato Dec 16 '10 at 10:51

4 Answers 4

up vote 8 down vote accepted

The encoding for \ell has changed in newer versions of the MinionPro font. The encoding in the LaTeX package still points at the old glyph code. To fix this, edit the base-MinionPro-ab.enc file. (In Windows, Search Everything is very helpful for this task.) Simply replace the text afii61289 with uni2113 and your script \ell characters will magically reappear. This works either before or after the LaTeX font is installed.

share|improve this answer

You can do it with these lines:

\DeclareSymbolFont{missing}{OML}{cmr}{m}{n}
\DeclareMathSymbol{\ell}{\mathord}{missing}{'140}

This declares an extra math font called "missing" (as in "missing symbols") which is Computer Modern's symbol font. Then it redefines \ell to point to the appropriate character in that font.

However, this apparently uses up one of the ridiculously few slots for math alphabets --- if you use any more, like \mathcal and \mathscr, then you get the dreaded "Too many math alphabets" error.

share|improve this answer

I don't have any version of minionpro installed, so I can't test, but in similar circumstances, one thing that has worked for me is to stick it in a savebox before loading the new font package, and then redefine the command to use the savebox, i.e., something like:

\documentclass{book}
\newsavebox{\oldell}
\savebox{\oldell}{\ensuremath{\ell}}
\usepackage{minionpro}
\renewcommand*{\ell}{\usebox{\oldell}}
\begin{document}
    $\ell$
\end{document}
share|improve this answer
    
Good answer, this is the kind of workaround I've been looking for. –  Emerson Oct 13 '10 at 8:18
    
This is a good hack, but it fails when you want to put \ell in a subscript. –  ptomato Dec 16 '10 at 10:51
    
Good point. That why hacks are hacks, and not real solutions. I guess a hackish workaround is to use a separate savebox for the subscript \newsavebox{\suboldell}\savebox{\suboldell}{\ensuremath{_\ell}}. –  frabjous Dec 16 '10 at 17:05

Quote from the MinionPro manual:

If you prefer another math font (such as eulervm) use the option onlytext as explained in Section 3.

Did you try that?

share|improve this answer
1  
Thanks for the answer, TechNixe. This changes the mathfont for the entire document, it's not exactly what I'm looking for. –  Emerson Oct 12 '10 at 18:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.