Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a MikTeX 2.9 installation on Windows 7. I can use CWEAVE AND CTANGLE with no issues. If I try

WEAVE sample.web null.ch sample.tex

I get an error WEAVE: Read operation failed.

The version is WEAVE, Version 4.4 (MiKTeX 2.9).

I searched on MiKTeX forums in vain. Anyone knows how to fix it, or where I can get an original source of `WEAVE to recompile if necessary?

share|improve this question
    
With windows you never know if it is a problem with access rights. Does the problem persist if you run the command from a “shell” with admin rights? –  uli Jan 1 '12 at 13:29
    
I have MiKTeX installed in one of my computers and I had the very same problem with weave. My wild guess is that weave is failing due to a problem in path searching. Trying weave from TeX Live worked like a charm. –  Paulo Cereda Jan 1 '12 at 13:55
    
@uli Thanks, I have been trying with running shell as administrator but still get the same problem. –  mathspasha Jan 1 '12 at 15:18
    
@PauloCereda I am just a bit worried to have the two installations installed on the same machine, as there are warnings in TeXLive not to do it. Can you help me do that? –  mathspasha Jan 1 '12 at 15:19
    
@mathspasha: I forgot to mention that my TeX Live install is in another computer. :) You are absolutely right, it's not recommended to have both TeX distros in the same operating system. –  Paulo Cereda Jan 1 '12 at 15:23

1 Answer 1

up vote 4 down vote accepted

With mathcing tex.web and etex.ch versions (in this case downloaded from the TeX Live SVN), I have no issues:

This is WEAVE, Version 4.4 (MiKTeX 2.9)
*1*17*25*38*54*72*99*110*115*133*162*173*199*203*207*211*220*256*268*289*297*300
*321*332*366*402*464*487*511*539*583*592*644*680*699*719*768*813*862*891*900*919
*942*967*980*1029*1055*1136*1208*1299*1330*1338*1340*1379*1598*1599
Writing the output file...*1*17*25*38*54*72*99*110*115*133*162*173*199*203*207*2
11*220*256*268*289*297*300*321*332*366*402*464*487*511*539*583*592*644*680*699*7
19*768*813*862*891*900*919*942*967*980*1029*1055*1136*1208*1299*1330*1338*1340*1
379*1598*1599
Writing the index...Done.
(No errors were found.)

However, I do see an issue if I have an empty .ch file, which your name null.ch suggests may be the case:

This is WEAVE, Version 4.4 (MiKTeX 2.9)
weave: Read operation failed.

So I think this is down to a defective .ch file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.