Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

If you're using an up-to-date system and you're having trouble with using the Linux Libertine fonts, you should probably check out Linux Libertine package and fonts not working any more (fall 2012), which deals with the current situation. The situation described in this question and its answer do not apply anymore to current systems.


Ever since an update in December 2011, libertine doesn't work anymore at all, the standard Computer Modern fonts are used instead. The minimal

\documentclass{article}
\usepackage{libertine}
\usepackage[T1]{fontenc}
\begin{document}
Hello World.
\end{document}

produces the error message

! Package libertine Error: Package is deprecated, use libertineotf!.

If I proceed accordingly and use libertineotf instead of libertine, I get 11 errors and no output:

! Package libertineotf Error: runs only with xelatex and lualatex!.

...

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
! Fatal fontspec error: "cannot-use-pdftex"
! 
! The fontspec package requires either XeTeX or LuaTeX to function.
! 
! You must change your typesetting engine to, e.g., "xelatex" or "lualatex"
! instead of plain "latex" or "pdflatex".
! 
! See the fontspec documentation for further information.
! 
! For immediate help type H .
!...............................................

I am indeed compiling with pdfLaTeX, but I don't want to switch to Xe/LuaLaTeX. Is there any way to get back the Linux Libertine fonts with pdfLaTeX?

I know the answer to this question, but I thought this matter is worth sharing -- expecting some Googlers looking for help. I've seen the answer in a couple of comments on here, so I'll wait a bit, assuming the answer will pop up.

share|improve this question
4  
In their infinite wisdom, the developers of Linux Libertine decided to drop support for pdflatex. As Herbert points out, the old package has been restored. –  egreg Jan 3 '12 at 11:13
add comment

1 Answer

up vote 17 down vote accepted

Update your system, then you'll get the old libertine package as libertine-legacy and then it should work as usual. The new package libertineotf supports only xetex and luatex.

With the current TeXLive and MiKTeX as of end of 2012 there is only one package libertine.sty which can be used as

\usepackage[options]{libertine}

Depending on what was run (xelatex/lualatex/pdflatex), it loads by itself the package fontspec or fontenc and does all the configuration.

share|improve this answer
5  
Additional: You will perhaps have to delete/rename the libertine.sty in libertineotf and update your file name data base so that your system finds and uses the libertine.sty from libertine-legacy. –  Ulrike Fischer Jan 3 '12 at 11:14
    
Works, thank you. Just to clarify: "as usual" means you still load \usepackage{libertine}, not \usepackage{libertine-legacy}. –  doncherry Jan 4 '12 at 12:36
    
@UlrikeFischer: In my MiKTeX 2.9, the folder containing the libertine.sty that had to be deleted (or just renamed, as I did) is called libertine, and not libertineotf. It seems like this deletion has to be done again every time libertine(otf) is updated, right? –  doncherry Mar 21 '12 at 14:14
1  
@doncherry: Yes the folder of the libertineotf-package is called libertine. And yes you would have to delete the sty after every update. A way to get around this could be to copy the libertine.sty from libertine-legacy to a local tree which is searched earlier. (And you would have to do it every time the sty in libertine-legacy is updated, but this shouldn't happen very often). –  Ulrike Fischer Mar 21 '12 at 14:29
    
Some comments, because things have changed. The libertine-legacy package doesn't exist any more; one can load libertine-type1 and biolinum-type1. As of today, a package libertine exists that should work similarly to the old package with the same name. –  egreg Oct 11 '12 at 11:45
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.