Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using MacTex-2011 on a mac 10.7. Recently, I have installed luximono using getnonfreefonts. Everything went ok, but when I was compiling the document (pdfLaTeX) with the packages:

\usepackage[T1]{fontenc} \usepackage{luximono}

luximono was not recognized, i.e. LaTeX used the standard font. Any ideas how to get it working?

share|improve this question
    
Stupid question: If you want Luximono as the standard text font, have you tried \renewcommand{\familydefault}{\ttdefault}? –  lockstep Jan 6 '12 at 11:41
1  
what does kpsewhich luximono.sty say? –  daleif Jan 6 '12 at 11:45
add comment

1 Answer

up vote 3 down vote accepted

Luxi Mono is a monotype font and not enabled by default. If you want to use it change the default tt font family, use \ttfamily or \texttt{..}.

By the way: it is not a good idea to set the complete document in a monotype font.

share|improve this answer
    
What is the reason for avoiding monotype fonts for the complete document? –  qubyte Jan 6 '12 at 13:09
    
compare it with another font ... However, if one has to submit an article to a journal, it may make sense to use a monotype font, counting charcters is easier. –  Herbert Jan 6 '12 at 15:48
    
Oh! I thought you meant Monotype Corp. Yes, I can obviously see why a monospaced font is a bad idea! –  qubyte Jan 6 '12 at 16:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.