Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

With Texmaker 3.1 on Win XP Pro SP2, the following MWE prints with different margin widths and font size according to whether, from the window which opens after I press F1, I use the print command directly or I click to open open my external viewer (Adobe Reader) and then print from that. I'm aiming for 1 inch margins and 10-point type.

\documentclass[a4paper,10pt]{article}
\usepackage[top=1in, bottom=1in, left=1in, right=1in]{geometry}
\usepackage{listings}
\usepackage{textcomp}
\usepackage{amsfonts}
\usepackage{amsthm}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{url}
\usepackage{enumerate}
\lstset{breaklines=true,numbers=left,numberstyle=\tiny,upquote=true,basicstyle=\fontsize{9pt}{6pt}\ttfamily}
\usepackage{graphicx}
\usepackage{epstopdf}
\usepackage{sidecap}
\usepackage{sectsty}
\partfont{\centering}
\DeclareMathSizes{12}{12}{8}{9}
\begin{document}
\title{Document Title}
\maketitle
The quick brown fox jumps over the lazy dog, but is it true that the quick brown dog jumps over the lazy fox?
\end{document}

Printing directly gives the required margins and type size. Firing up Adobe Reader first gives L,R margins of 1.34in and 1.02in respecively, and type size that's clearly smaller than 10pt: the number of characters per line and the layout are the same; it's as if the whole page has been reduced.

share|improve this question
1  
As someonr implied, this is not a minimal working example. You could probably get rid of all packages except geometry to reproduce this behavior. Have a look at meta.tex.stackexchange.com/questions/228/…. –  doncherry Jan 7 '12 at 1:13
4  
Thanks for this. I'll post proper MWEs from now on! :) –  Harry Macpherson Jan 7 '12 at 1:52
add comment

1 Answer

up vote 4 down vote accepted

I tested it and everything is working perfect.

Probably Adobe Reader is causing your problem. Disable the scale to page feature in print settings and try again.

Next rime please reduce your MWE so that only the packages that are causing the error are represent.

share|improve this answer
    
Problem fixed; thanks! –  Harry Macpherson Jan 7 '12 at 1:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.