Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to suppress page numbers. I am also using \maketitle command which seems to trigger the problem. MWE:

\documentclass[a4paper,10pt,english]{article}
\title{My title}
\begin{document}
    \thispagestyle{empty}
    \maketitle
    Hello World
\end{document}
share|improve this question
add comment

2 Answers 2

up vote 17 down vote accepted

You need to set the page style after \maketitle since \maketitle sets the page using \thispagestyle{plain} (which overwrites your request for it to be empty):

\documentclass[a4paper,10pt,english]{article}
\title{My title}
\begin{document}
 \maketitle
 \thispagestyle{empty}% Reset page style to 'empty'
 Hello World
\end{document}

If you wish to suppress the page numbering for all pages within your article, you should add \pagestyle{empty} to your document preamble.

The article document class also supports the titlepage option, which typesets an entire page (a titlepage) when using \maketitle. Such a page is necessarily issued using \thispagestyle{empty}. That is, without any header/footer.

share|improve this answer
    
@Elec: If you want to suppress all page numbers (and other header and footer text) use \pagestyle{empty}. –  Tobi Jan 9 '12 at 20:07
add comment

To suppress page numbers on every page regardless of the page style(s) used by the document class, add \pagenumbering{gobble} to your preamble.

share|improve this answer
    
\gobble and friends are nifty. –  Werner Jan 9 '12 at 20:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.