Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using biblatex+biber for the bibliography of my thesis. I use the numeric-comp citation style. Overall this works perfectly.

I generally use \cite to cite references; but occassionally also \cites, namely when I want to cite references in a specific (non-numeric) order, or when I want to specify page numbers for some (but not all) cited references using postnotes (i.e. between []).

My question is about the latter usage of \cites, for example:

\cites[pp.173--199]{SomeBook}{SomePaper}

Which produces (10=SomeBook; 20=SomePaper):

[10, pp.173–199, 20]

I find the commas slightly confusing here. Therefore I was wondering if it is possible to somehow tell biblatex to use another separator, say a semicolon. So that I would get:

[10, pp.173–199; 20]

However, I do not want to replace commas with semicolons everywhere, only in this specific case. So all uses of \cite, and uses of \cites without postnotes, should still use commas.

If necessary I would be ok with a solution based on a separate command for the specific case. For example a \semicites command that uses a differently configured \cites internally.

EDIT 2 I changed my mind and went with a solution based on Marco's answer.

share|improve this question
add comment

2 Answers 2

up vote 11 down vote accepted

First of all I want to recommend the documentation of biblatex.

Next to the documenation the file biblatex.def is very useful for every user. There you can find every default definition of userdefined commands.

You are looking for the command \multicitedelim. The default setting in version 1.7 is a semicolon:

\newcommand*{\multicitedelim}{\addsemicolon\space}

The style numeric redefines the multicitedelim in the file numeric.cbx.

\renewcommand*{\multicitedelim}{\addcomma\space}

To set the default setting simple use:

\renewcommand*{\multicitedelim}{\addsemicolon\space}
share|improve this answer
    
Thanks! But how do I apply this without changing a commas to semicolons? (cf. my question) –  Matthias Jan 10 '12 at 12:43
1  
@Matthias It would be rather inconsistent to use different punctuations for the same situation. –  egreg Jan 10 '12 at 13:15
    
Maybe, yet it is what I had in mind and explained above. –  Matthias Jan 10 '12 at 13:21
1  
Shouldn't this be \renewcommand*{\multicitedelim}{\addsemicolon\space}? –  lockstep Jan 10 '12 at 17:19
    
@lockstep: Typical copy-paste ;-) –  Marco Daniel Jan 10 '12 at 19:46
add comment

For my thesis (phys style) I now went with your original request. I define a new multicite command \semicites:

\DeclareMultiCiteCommand{\semicites}[\mkbibbrackets]{\cite}{\addsemicolon\space}

which gives me an output like [280–282; 6, S. 88] while leaving all other multicites intact, e.g. [12, 15, 20].

As the former case appears very few times—at the moment once :)—I decided to have this inconsistency, but keep the commas for almost all citations, as that looks better to me (maybe I'm only used to it).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.