Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I try to create my file with TeXLipse, it never creates the bibliography information correctly. I set up everything as described in the various tutorials.

The current setup is like this:

/
/src
/src/doc.tex
/src/Bibliography.bib

I use \bibliography{Bibliography} to include the file and \cite{abc} to cite. But TeXLipse doesn't seem to build the bibliography correctly, and also it doesn't recognize the references for autocompletion when using \cite{...

Do I somehow need to set up the builders in a different order, and if so, how do I do that in Eclipse?

share|improve this question
    
Maybe you're missing \bibliographystyle{plain}? –  user13495 Apr 11 '12 at 20:40
add comment

2 Answers 2

In short, it seems that TeXLipse does not like sub-folders

More details on this other conversation can be of help Bibtex not showing using TexLipse (too bad it has been closed)

I am using MikTeX and, if I avoid using subfolders, sometimes it works sometimes it doesn't. The problem still seems to be that Bibtex is not run!

share|improve this answer
    
Welcome to TeX.SX! –  Claudio Fiandrino Nov 21 '13 at 11:08
add comment

The following is too long for a comment.

It's important to provide a minimal example. Word phrases like "TeXLipse doesn't seem to build the bibliography correctly" aren't useful. We need specific information. However I can imagine that you are using TeX Live. In TeX Live you have restrited rules for including such file. The rules are located in the file texmf.cnf. It is located in the folder: texlive/2011/texmf/web2c. The file contains next to the definitions a documentation where you can find:

% Allow TeX \openin, \openout, or \input on filenames starting with `.'
% (e.g., .rhosts) or outside the current tree (e.g., /etc/passwd)?
% a (any)        : any file can be opened.
% r (restricted) : disallow opening "dotfiles".
% p (paranoid)   : as `r' and disallow going to parent directories, and
%                  restrict absolute paths to be under $TEXMFOUTPUT.
openout_any = p
openin_any = a

So I suggest to change the parameter openout_any=p to openout_any=a whereby the changes took place in the file

/usr/local/texlive/2011/texmf.cnf
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.