Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Since recently I am using LuaLaTeX with the most recent beta version of Microtype, along with the fonts Minion Pro and Myriad Pro. In the manual of Microtype it says:

    Currently, this package provides protrusion settings for [...] Adobe Garamond and Minion, [...] as well as some generic settings for unknown fonts
(cf. table 3 on page 21)

Currently, I just include the fonts like this (with some other font definitions for headings etc. settings left out here):

\defaultfontfeatures{Ligatures=TeX, Scale=MatchLowercase}

\setmainfont[SmallCapsFeatures={LetterSpace=6}, Numbers={Proportional,OldStyle}]{Minion Pro}
\setsansfont[LetterSpace=3, Numbers={Proportional,OldStyle}]{Myriad Pro}

But this way I still get the following message from Microtype:

Package microtype Warning: Loading generic settings for font family `MinionPro'

How can I load the correct settings? Also, is there a way to avoid all these warnings I get for fonts that are not supported, and Microtype just loads the generic settings?

share|improve this question
4  
AFAIK the default settings of microtype are for the Type1 variant of traditional LaTeX. Since you're using LuaLaTeX and fontspec you're probably using a much newer OpenType version of the fonts. Therefore the settings microtype comes with are useless for you. You need completely new ones – which don't exist yet, at least not publicly. –  Simifilm Jan 10 '12 at 17:42
    
If that is the case, just copy your comment in an answer and I'll accept it for as long as no real solution exists. –  Ingo Jan 10 '12 at 18:08

3 Answers 3

up vote 14 down vote accepted

With the current microtype from TeXlive 2011, you can do the following:

\documentclass{article}
\usepackage{fontspec,microtype}
\defaultfontfeatures{Ligatures=TeX, Scale=MatchLowercase}


\setmainfont[SmallCapsFeatures={LetterSpace=6}, Numbers={Proportional,OldStyle}]{Minion Pro}
\setsansfont[LetterSpace=3, Numbers={Proportional,OldStyle}]{Myriad Pro}


\SetProtrusion
   [ name     = min-eu2 ]
   { encoding = {EU2},
     family   = MinionPro  }
   {
     {,} = {  ,500},
      -  = {  ,500}
   }


\begin{document}
  \hsize 3in

When, while the lovely valley teems with vapour around me, and the meridian sun strikes the upper surface of the impenetrable
foliage of my trees, and but a few stray gleams steal into the inner sanctuary, I throw myself down among the tall grass by the
trickling stream; and, as I lie close to the earth, a thousand unknown plants are noticed by me.

\end{document}

LuaTeX with fontspec uses EU2 encoding internally, so all you need to do is the regular microtype setup with encoding EU2.

share|improve this answer
1  
The setting . = { ,500}, should also be used. However it makes no real difference to the output without \SetProtrusion –  Herbert Jan 10 '12 at 19:37

Hm, I also use Minion Pro and Myriad Pro … this way:

\documentclass[12pt]{scrbook}
\usepackage[english]{babel}
\usepackage{blindtext}
\pdfprotrudechars=2
\pdfadjustspacing=2
\usepackage{fontspec}
\defaultfontfeatures{Ligatures=TeX}
\newfontfeature{Microtype}{protrusion=default;expansion=default;}
\setmainfont[Microtype,Ligatures=TeX,Numbers=OldStyle]{Minion Pro}
\setsansfont[Microtype,Scale=MatchLowercase,Ligatures=TeX,Numbers=OldStyle]{Myriad Pro}
\begin{document}
\blindtext[5]
\end{document}

Than TeX Live 2010 and now 2011.

share|improve this answer
1  
Nice solution, easier than mine. –  topskip Jan 27 '12 at 21:52
    
Well, I have to state that I did not invent this by my own, but in de.comp.text.tex someone gave me a hint and it worked like a charm. –  Alabay Jan 27 '12 at 22:02
    
“Someone” was Ulrike Fischer, IIRC. You should add a remark, that your solution doesn’t make use of the package microtype. Or am I wrong (question @LuaTEXperts)? –  Speravir Jan 28 '12 at 0:38
    
Well, as I had not asked her if she'd agree that I post her name, and as I was not quite shure I preferred “someone”, you seem to know and have asked her. And I was thinking about that microtype exactly as you mentioned … but I am not quite sure (again) due to microtype is mentioned. So, I'm not so deep into it to judge if it's the same microtype. But I know that this way is a grandious solution to use those two fonts with . And that's the reason I mentioned it here. –  Alabay Jan 28 '12 at 16:59
1  
Ulrike is active here, too, so I don’t see a problem. Concerning microtype: The OP wrote about the package, your solution does not use it – that’s the only thing, what I wanted to remark. OTOH I do not know, whether the package has more features now in the beta version. For that we need a person, that I've called “LuaTeXpert”. –  Speravir Jan 28 '12 at 23:34

The user guide for version 2.5/beta08 of the microtype package states that the kerning, spacing, and tracking options are not (yet) functional if microtype is used with Lua(La)TeX. It may well be the case that other capabilities -- such as the ability to load specialized configurations via .cfg files -- aren't fully functional either when used with Lua(La)TeX.

At any rate, what you're getting is not an error message but "just" a warning message. You may wish to send the author of the microtype package a message to inquire if and when an updated version of the file mt-MinionPro.cfg might become available; the file that currently comes with the package has a file date of 2005/02/07.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.