Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Could someone help me with multibib? On windows machine with texlive 2011 installed the following file hangs during compilation:

\documentclass{article}
\usepackage{multibib}
\newcites{pub}{Publications}
\newcites{con}{Conferences}
\begin{document}
\end{document}

Of course, it is a minimal not-working example and it is not very informative. But the error is the same and this latex file is supposed to be correct. The compilation stops at the following lines:

Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(c:/texlive/2011/texmf-dist/tex/latex/base/size10.clo))
(c:/texlive/2011/texmf-dist/tex/latex/multibib/multibib.sty) (./pub.aux)
(./con.aux

It just stops. If I do ctrl+c I see the following:

! Interruption.
<argument> ...@auxout\@suffix name\endcsname .aux}
                                                  \endgroup \immediate \open...
l.5 \newcites{con}{Conferences}

?

I have no idea where this problem comes from. I have tried to google, but it seems that this error is not something well-known.

UPD It seems that it is a bug of texlive at windows. I would be hapy if someone gave me any clue how to find where exactly the problem occurs.

share|improve this question

closed as too localized by lockstep, Stefan Kottwitz Feb 5 '12 at 10:15

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
It compiles, for me. –  egreg Jan 11 '12 at 13:15
add comment

1 Answer 1

I've tested the following minimal example using multibib with TeX Live 2011 on Windows 7, and it works for me. The compilation steps were

pdflatex test.tex bibtex test.aux bibtex www.aux pdflatex test.tex

EDIT: It also works using latexmk.

\listfiles
\documentclass{article}
\usepackage{multibib,url}
\bibliographystyle{alphadin}
\newcites{www}{Weblinks}
\bibliographystylewww{plain}
\usepackage{filecontents}
\begin{filecontents*}{literatur.bib}
 @misc{test,
 author={Hans Hansi},
 title={Titel},
 year=1900,
}
\end{filecontents*}
\begin{filecontents*}{www.bib}
 @misc{test1,
 author={tex stackexchange},
 title={Strange bug with multibib},
 year=2011,
 howpublished={\url{http://tex.stackexchange.com/questions/40743/strange-bug-with-multibib}}
}
\end{filecontents*}
\begin{document}
\nocite{*}
\nocitewww{*}
\bibliography{literatur}
\bibliographywww{www}
\end{document}

enter image description here

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.