Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I didn't find a solution in the web, so I'm asking here.

I am using authoryear-icomp style for my bibliography (without any modification). When I have a BibTeX entry like:

@online{guizzo_i-limb_2008,
title = {{i-LIMB} snatches {MacRobert} Award - {IEEE} Spectrum},
url = {http://spectrum.ieee.org/automaton/robotics/robotics-software/ilimb_snatches_macrobert_award},
abstract = {{IEEE} Spectrum},
journal = {{IEEE} Spectrum},
author = {Guizzo, Erico},
month = jun,
year = {2008}
},

I get the URL twice in the bibliography. Once in the url field with nice linebreaks and once rudely running into the margins:

Guizzo, Erico (June 2008). i-LIMB snatches MacRobert Award - IEEE Spectrum.
http://spectrum.ieee.org/automaton/robotics/robotics-software/ilimb_snatches_macrobert_award.
URL: http://spectrum.ieee.org/automaton/robotics/robotics-software/ilimb_
snatches_macrobert_award.

How do I get rid of the entry not starting with URL (that is the one without linebreak)?

share|improve this question
2  
Btw, I'd recommend replacing the hyphen - in your title (MacRobert Award - IEEE Spectrum) by an en dash -- or em dash ---. –  doncherry Jan 12 '12 at 1:01
add comment

2 Answers

up vote 4 down vote accepted

It was a matter of some old files in the temp directory par-username. There has been a howpublished = {http://spectrum.ieee.org/automaton/robotics/robotics-software/ilimb\_snatches\_macrobert\_award} entry that is not wrapped.

share|improve this answer
    
BTW: disabling howpublished by \printbibliography[nottype=howpublished] does not work sadly. I have to delete the howpublished entry –  louis cypher Jan 12 '12 at 14:56
3  
type and nottype specify an entry type. In the entry you give above it is online. You can clear the howpublished field without having to edit the bib file. Details can be found in this post. –  Audrey Jan 12 '12 at 18:10
    
I found also in the manual that 'type' does not work. Thanks for the link. That exactly does what I need. –  louis cypher Jan 15 '12 at 21:02
    
Good to hear. Using the type or nottype options wouldn't fix your problem - they simply filter entries by type. For example type=online makes \printbibliography list only online entries. –  Audrey Jan 16 '12 at 16:49
add comment

(answer / long comment with pic)

From your description I gathered the following MWE:

\documentclass{article}

\usepackage[style=authoryear-icomp,backend=biber]{biblatex}

\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@online{guizzo_i-limb_2008,
title = {{i-LIMB} snatches {MacRobert} Award - {IEEE} Spectrum},
url = {http://spectrum.ieee.org/automaton/robotics/robotics-software/ilimb_snatches_macrobert_award},
abstract = {{IEEE} Spectrum},
journal = {{IEEE} Spectrum},
author = {Guizzo, Erico},
month = jun,
year = {2008}
}
\end{filecontents*}

\addbibresource{\jobname.bib}

\begin{document}
\nocite{*}

\printbibliography
\end{document}

No matter whether I use backend=biber or backend=biblatex, I can't reproduce your problem, this is my output:

Make sure your system is up-to-date. If that doesn't help, please post a minimal working example (MWE) that reproduces your problem.

share|improve this answer
    
My system is as up to date as possible (miktex2.9 updated yesterday) ;-) I tried to build a MWE and the funny thing is: The problem dissapears =-/. I will now try to strip down my 1600 lines bib file down to find the problem (puuuuuh) @doncherry –  louis cypher Jan 12 '12 at 10:11
    
BTW: I am using book not article –  louis cypher Jan 12 '12 at 10:17
    
You could as well try getting rid of all auxiliary files (e.g. via latexmk -c foo.tex) and comiling again. If that doesn't help, let us know when you've got the MWE. The difference between article and book doesn't matter in this case, hence using article is better for a MWE since it's simpler. –  doncherry Jan 12 '12 at 11:21
    
I have a MWE on the latex side. Not yet on the bib file side. If I isolate the entry I do not have that behaviour anymore =-( –  louis cypher Jan 12 '12 at 14:06
    
Try eliminating small bits of your source and compile to see where the error disappears. –  doncherry Jan 12 '12 at 14:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.