Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I just started using LaTeX, and need to use the character "ü". I already have this in main file :

%%% Sprach- und zeichensatzspezifische Pakete
\usepackage[latin9]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{ngerman}
\usepackage{array}

where I believe the latin9 inputenc will allow me to show ü in the PDF file. However, when I type pdflatex main, I get the PDF file, where the word für is rendered as fÃŒr

There is no error, and the package is already there (if not, for sure it will prompt me for error message). How to render this "ü" in PDF? Would appreciate any answer.

share|improve this question

migrated from stackoverflow.com Jan 13 '12 at 11:33

This question came from our site for professional and enthusiast programmers.

    
Welcome to TeX.sx! Your question was migrated here from Stack Overflow. Please register on this site, too, and make sure that both accounts are associated with each other, otherwise you won't be able to comment on or accept answers or edit your question. –  doncherry Jan 13 '12 at 12:04

4 Answers 4

up vote 2 down vote accepted

I don't know how to get the character to work, but you can just use \"u to get a "ü" in the pdf.

share|improve this answer

Instead of changing every single umlaut manualy, you should better use a complete utf8 workflow, as Jouni suggested. This will save you a lot of work! Just replace the lines you posted (and maybe parts of your documentclass) with the following:

\documentclass[
    a4paper,
    ngerman
]{scrbook}

\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[utf8]{inputenc}
\usepackage[]{babel}

\begin{document}
  Write üöäß directly!
  And é and è and çñâøæð.
\end{document}

Using UTF8 makes your life easier, but it means you need a UTF8 capable editor. Personally, I really like Texmaker, which is UTF8 capable, has a nice and simple GUI and is available for free for Windows, Linux and Mac OS. And you need to save your files as UTF8.

Maybe you'll also find the following questions helpful:

share|improve this answer

Looks like your editor saved the file in utf-8. Try changing the latin9 parameter to utf8.

share|improve this answer

For languages other than English you can choose a semiautomatic input selection. For German replace the inputenc package with these lines.

\usepackage{selinput}
\SelectInputMappings{
  adieresis={ä},
  germandbls={ß},
  Euro={€}
}

The selinput package is part of the oberdiek bundle. It will select the right input encoding in dependence of the file encoding.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.