Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Hiya, Is it possible to set the \setcounter{tocdepth}{..} for one chapter only?

The default depth is fine for the entire document, except for the last chapter- I only want the chapter title to appear in the table of contents (all sections, subsections etc should not appear).

I could adjust all of my sections to use an asterisk, eg \section*{...} which will cause them to not be numbered and not show up in the ToC, however I want these sections to be numbered! (I have references to these numbers elsewhere).

I have tried placing \setcounter{tocdepth}{1} to the chapter I want this to apply to, and have tried adding it to my main tex file before the \include of that chapter, doesn't seem to work (I guess because \maketitle has already been called by that stage?)

Any suggestions?

share|improve this question

1 Answer 1

up vote 9 down vote accepted

If I understand you right, the code below should do what you want.

\documentclass[11pt,a4paper,english]{report}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{blindtext}

\begin{document}
  \tableofcontents

  \blinddocument

  \addtocontents{toc}{\protect\setcounter{tocdepth}{0}}
  \blinddocument
\end{document}

Setting the counter tocdepth to »1« would also show the sections.

share|improve this answer
    
Damn. I missed posting this answer by a few seconds. I think you need 1 to see sections and 2 for subsections, at least in the book class. –  frabjous Oct 13 '10 at 21:07
    
Thanks. Correction done. –  Thorsten Donig Oct 13 '10 at 21:09
1  
It would also help the relatively uninitiated that the \blindtext package and the \blinddocument commands are just for generating dummy, testing texts. They are not part of the solution. –  Willie Wong Oct 13 '10 at 21:59
    
Thanks, that works perfectly. And thanks also Willie Wong, that would have been pretty confusing figuring out why all my content suddenly changed... :p –  elwyn Oct 14 '10 at 20:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.