Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using beamer and have a frame too long to fit in a single frame, so I use the option

\begin{frame}[allowframebreaks]

Because I want my list items to be exposed gradually, I am using

\beamerdefaultoverlayspecification{<+->}

before everything. However, this causes only my first item in the first frame to be exposed. The rest are just shaded, for some reason...

How can I fix this? (have both long frames and gradual presentation)?

Here is a MWE:

\documentclass{beamer}

\mode<presentation>
{
  \usetheme{Warsaw}
  \setbeamercovered{transparent}
}

\usepackage[english]{babel}
\usepackage[latin1]{inputenc}
\usepackage{times}
\usepackage[T1]{fontenc}
\title[]{Hello World}

\AtBeginSubsection[]
{
  \begin{frame}<beamer>{Outline}
    \tableofcontents[currentsection,currentsubsection]
  \end{frame}
}

\beamerdefaultoverlayspecification{<+->}

\begin{document}

\begin{frame}[allowframebreaks]{Hello}
    This is a very long frame:
    \begin{itemize}
        \item 
        line\\ line\\ line\\ line\\ line\\ line\\ line\\ line\\ line\\ line\\ 
        \item 
        line\\ line\\ line\\ line\\ line\\ line\\ line\\ line\\ line\\ line\\ 
        \item 
        line\\ line\\ line\\ line\\ line\\ line\\ line\\ line\\ line\\ line\\ 
    \end{itemize}
\end{frame}

\end{document}
share|improve this question
    
Would you please add an example of the frame in question? –  egreg Jan 14 '12 at 14:17
    
I added an example. (My real presentation involves much math which is irrelevant) –  Elec Jan 14 '12 at 14:26
    
It isn't a minimal example. I tried what you list with \documentclass{beamer} and I cannot see anything wrong with it. –  Marc van Dongen Jan 14 '12 at 14:34
    
I get no shaded text. Please, turn the example into a MWE. –  egreg Jan 14 '12 at 14:38
    
Here, I have completed it into a full MWE –  Elec Jan 14 '12 at 15:49

1 Answer 1

It is not possible.

The combination of [allowframebreaks] and overlays is not supported by the current implementation of beamer [beameruserguide, p.51]:

You can use the option allowframebreaks to cause the ⟨frame text⟩ to be split among several slides, though you cannot use overlays then. See the explanation of the allowframebreaks option for details.

The documentation for [allowframebreaks] states further [beameruserguide, p.60]:

allowframebreaks=⟨fraction⟩. When this option is given, the frame will be automatically broken up into several frames if the text does not fit on a single slide. In detail, when this option is given, the following things happen:

  1. Overlays are not supported.

    ...

share|improve this answer
    
Thanks. But why would it be like that? I mean, is there a technical difficulty to implement both of them? it seems like a serious bug. Is there a different way to break the frames, and also use overlays, or anyway to reveal the items gradually? –  Elec Jan 14 '12 at 15:38
    
@Elec: It is technically and semantically difficult to implement this, as overlays may also change the amount of content, so that depending on the overlay more or less frames (note that we are not talking abut slides, but frames with distinct frame numbers) would be necessary. However, it is also by design: The documentation makes it pretty clear that Till Tantau considers allowframebreaks as a valid option for long bibliographiews, but as very, very bad style for anything else. –  Daniel Jan 17 '12 at 16:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.