Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am following the directions in the README at the CTAN entry for MinionPro. I am using the Minion Pro fonts from the Adobe Font Folio 11. I'm running a fully-updated TeX Live 2011 distribution on OS X Lion 10.7.2.

Please note that I'm entirely aware this can be solved by using XeLaTeX (with fontspec), but I wish to use LaTeX in this case.

Running otfinfo -v on any one of the 64 Minion Pro fonts yields,

Version 2.030;PS 2.000;hotconv 1.0.51;makeotf.lib2.0.18671

so naturally I'm using the enc-2.000.zip encoding files.

After unzipping metrics-base.zip, metrics-full.zip, metrics-opticals.zip, and enc-2.000.zip into my /usr/local/texlive/texmf-local directory, I ran sudo mktexlsr, then sudo updmap-sys --enable Map=MinionPro.map, then sudo mktexlsr again.

I then typeset my test file, whose code and output is shown below.

\documentclass[10pt]{article}
\usepackage[T1,T2A]{fontenc}
\usepackage[openg]{MinionPro}
\usepackage[utf8]{inputenc}
\usepackage[english,russian]{babel}

\begin{document}
\section*{English}
Hello! How are you? This sentence has \textbf{bold}, \textit{italic}, and \textbf{\textit{bold italic}} characters. This sentence has \textsc{small caps}.

\section*{Russian}
Здравствуйте! Как у вас дела? Это предложение имеет \textbf{жирные}, \textit{курсивные}, и \textbf{\textit{жирные курсивные}} буквы. Это предложение имеет \textsc{капительные буквы}.

\section*{Equations}
\[
  \psi_{nlm}(r,\theta,\rho) = \sqrt{\bigg(\frac{2}{na_0}\bigg)^3 \frac{(n - l - 1)!}{2n[(n + l)!]^3}} e^{-\rho / 2} \rho^{l} L_{n - l -1}^{2l + 1}(\rho) \cdot Y_{l}^{m}(\theta, \phi)
\]
\[
  y = x\tan(\theta) - \frac{g\sec^2(\theta)}{2v_0^2}x^2
\]
\end{document}

image of test code output

Note that the openg option also fails to display. This is strange to me, because it seems as if everything is working except for a few characters. Everything works great with XeLaTeX, but not when using the MinionPro package.

Forgive me if I'm being naïve. Thanks.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

the current TeXLive version of MinionPro has no option [openg]. Without it I get the desired result.

enter image description here

With lualatex and

\documentclass[10pt]{article}
\usepackage{fontspec}
\setmainfont{Minion Pro}
\usepackage[english,russian]{babel}

I get the same output.

share|improve this answer
    
Thanks for your reply, but I'm aware this can be acheived using fontspec. I'm only perplexed as to why it won't work with pdflatex. –  user2473 Jan 16 '12 at 22:40
    
I used pdflatex, so it is a problem with your font setting. –  Herbert Jan 16 '12 at 22:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.