Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I cannot create glossaries on my WinXP setup of MiKTeX 2.8, which I installed about half a year ago together with a TeXnicCenter from a distribution that I downloaded from TUG. The document does compile correctly on my friend's LaTeX setup (on a Linux computer), so as far as I can tell the code is correct, but something is wrong with my compiler. The following three lines appear in the Output Window of TeXnicCenter:

Couldn't find input index file C:\Test-mapp\Testfil nor
C:\Test-mapp\Testfil.idx.

Usage: C:\Program Files\MiKTeX 2.8\miktex\bin\makeindex.exe
[-ilqrcgLT] [-s sty] [-t log] [p num] [idx0 ix1 ...]

Scanning style file
C:/Test-mapp/Testfil.ist...........................done (27 attributes
redefined, 0 ignored).

In my document, I have the following lines:

\usepackage{glossaries} % this is in the preamble

\makeglossaries % also in the preamble

\printglossaries % in one of the sections of the document

Since the document compiles on my friend's system, I am quite sure that the problem is with my compiler, not the LaTeX code. Do you have any suggestions on what is happening or what I can do to solve this? Other functions of the glossaries package do work also on my system, like for example the use of abbreviations, so I do have the package installed. It is only \makeindex that does not work.

edit:

Thank you for your input. The code below does not generate any glossaries on my system, and I believe it should.

\documentclass{article}

\usepackage{glossaries}


\newacronym{SEM}{SEM}{scanning electron microscope}

\newacronym{TEM}{TEM}{transmission electron microscopy}

\newacronym{UHV}{UHV}{ultra-high vacuum}

\makeglossaries

\begin{document}


\section{First Section}

\label{Intro}

Intro

\section{List of variables}

\label{LoV}

\printglossaries 

\end{document}
share|improve this question
1  
Please edit your post to include a minimal working example (MWE). \makeindex is obviously failing, but it's hard to determine why given the limited information. –  Mike Renfro Jan 17 '12 at 14:53
    
As far as I can see, the error you reported is not related to glossaries at all. Usually, the LaTeX => PDF profile in TeXnicCenter runs makeindex for every document; in this case, as you don't have any indices, it will complain because there's no .idx file. You can safely ignore this "error". If I'm not mistaken, you need to run makeglossaries in order to generate the entries for your glossaries in the document. –  Paulo Cereda Jan 17 '12 at 15:44
    
Thank you for your replies. The problem is that I cannot get the program to make a list of the three defined acronyms with \printglossaries. Since this problem does not appear on my friend's system, I am quite sure that the problem is with my system rather than the code, and I am at a loss on how to correct it. –  hjb981 Jan 17 '12 at 16:17
add comment

1 Answer

up vote 3 down vote accepted

Paulo is correct in the comments above. You need an external program (makeglossaries or makeindex) to generate the glossary data. Also, you failed to use any of your acronyms in your document, so they were never put in the glossary list. The following document works:

\documentclass{article}
\usepackage{glossaries}

\newacronym{SEM}{SEM}{scanning electron microscope}
\newacronym{TEM}{TEM}{transmission electron microscopy}
\newacronym{UHV}{UHV}{ultra-high vacuum}

\makeglossaries

\begin{document}
\section{First Section} \label{Intro}

Intro. At some point, we used a \gls{SEM}.

\section{List of variables} \label{LoV}

\printglossaries
\end{document}

with the a TeXnicCenter build profile similar to the following (adjust paths to makeindex as needed -- I just copied an existing build profile to make this one):

enter image description here

Make sure that Makeindex runs from TeXnicCenter, and has the arguments

"%tm".glo -t "%tm".glg -s "%tm".ist -o "%tm".gls

yielding a PDF

enter image description here

share|improve this answer
    
Thanks very much for your help and also for the comments previously! I minimized my MWE a tad too much---the original (long) document included the use of the acronyms. My bad. In my settings, I used to have "%bm" as argument for makeindex, instead of "%tm".glo -t "%tm".glg -s "%tm".ist -o "%tm".gls, like you suggested. Thanks also for making my post look nicer, btw (the formatting with different boxes around code etc). –  hjb981 Jan 17 '12 at 20:19
    
%bm (expands to full path of main file) may still work on older MiKTeX versions, but TeX Live added some security restrictions preventing some access to files specified with full paths, so I use %tm (expands to relative path of main file) now. I'd expect MiKTeX to do something similar in future versions, assuming they've not changed already. –  Mike Renfro Jan 18 '12 at 17:54
    
I have %bm as the argument also for BiBTeX, which works on my system, but my TeXnicCenter says Stable Release Candidate 1.0, and may not be the latest (I downloaded it a little over half a year ago). –  hjb981 Jan 18 '12 at 18:05
    
TeXnicCenter wouldn't be the source of the problem, regardless (it's just an editor). MiKTeX, TeX Live, etc. (TeX distributions) would be. –  Mike Renfro Jan 18 '12 at 18:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.