Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Possible Duplicate:
tlmgr is not accessible after installing TeX Live 2011 on a Ubuntu system

I just installed TeXlive with the install-tl-20120117 package. I expected to be able to use tlmgr after the installation but bash came up with the error tlmgr: command not found.

I checked whether or not the file tlmgr.pl is in /usr/local/texlive/2011/texmf/scripts/texlive and it is. Can anyone tell me what I'm doing wrong? I'm still trying to learn the ropes here.

EDIT in Response: I am running Debian Squeeze on VirtualBox.

echo PATH
/home/pjh/.rvm/gems/ruby-1.9.3-p0/bin:/home/pjh/.rvm/gems/ruby-1.9.3-p0@global/bin:/home/pjh/.rvm/rubies/ruby-1.9.3-p0/bin:/home/pjh/.rvm/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

I think I see the problem, how do I mend this? What should I add to the path? Should I add it in my .bashrc?

share|improve this question
    
It would be helpful to know your OS. Also, have a look at this: tex.stackexchange.com/questions/26624/… –  Psirus Jan 19 '12 at 10:16
    
Have you added the newly installed TL to your PATH? Otherwise bash cannot find it. If you have, verify the PATH variable (echo $PATH) –  daleif Jan 19 '12 at 10:23
    
How would I go about doing that? –  Patrick Hisshion Jan 19 '12 at 10:31
    
Thanks Marc, I've tried that according to the thread that Psirus posted above. Still gives me the same error, even after reloading. Do I have to dictate the PATH in a config file? Specifically tlmgr is in /usr/local/texlive/2011/bin/i386-linux. Which really is a symlink to ../../texmf/scripts/texlive/tlmgr.pl –  Patrick Hisshion Jan 19 '12 at 11:00
1  
Usually, you would run tlmgr as root. Which means you will have to add the path to tlmgr to the root's path. I have no idea how to do that on Ubuntu, they do not really use a root account, and do that sudo thing instead. –  Jan Hlavacek Jan 19 '12 at 15:06
show 20 more comments

marked as duplicate by Sharpie, egreg, Seamus, lockstep, Stefan Kottwitz Jan 21 '12 at 12:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

Please see the section on setting the PATH in the quick install for TL and check the documentation of your OS.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.