TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using WinEdt(Build: 20110315 (v. 6.0)) with MiKTeX(2.9.4282). I have used it for years, it was all OK one hour ago. But now I cannot click the button to run the cmd. I do not know what I did any thing wrong. When I click the pdflatex icon(or any others cmd, next the recycle bin icon), it simply says in the windows

Startup folder: E:\Poster_Li

Error launching Console Application PDFLaTeX Command Line: pdflatex.exe "filename.tex" Startup Folder: E:\Poster_Li

Invalid folder name (above in English, this line is given in local language).

It seems that the Startup folder is fixed to E:\Poster_Li. I have deleted E:\Poster_Li. On the other hand, I can still use cmd line such as pdflatex filename.tex to compile files (I do not like this way.).

share|improve this question
It sounds like you have a "portable" MikTeX installation whose root directory is located on the (logical) E: drive. Did you maybe mount another USB drive and, as a result, the physical device that was assigned to E: is now at F: (or somewhere else altogether)? If so, try to reboot the machine in the standard setup and check if the Miktex distribution is back under E:. – Mico Jan 20 '12 at 2:05
@Mico Thanks for the comment. I am not using portable MikTeX. After reboot, the problem remains. – Ma Ming Jan 20 '12 at 7:12
@Holle Thank you so much. Your trick works! Yes, I deleted some file when it is opened in WinEdt. After that when I open any file the problem happens. – Ma Ming Jan 20 '12 at 18:47
@Holle Please turn your comment into an answer. – lockstep Mar 3 '12 at 21:39
up vote 1 down vote accepted

In WinEdt the startup folder is not fixed. The startup folder is the folder where the mainfile is located. But you have to tell WinEdt which your mainfile is: Open filename.tex and execute WinEdt->Project->Set Main File. Maybe you renamed or moved you folder without setting the mainfile.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.