Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Edit: having tried to make a MWE the issue I was having has gone away - so please disregard!

I'm having trouble with a reference to a work by MIT, I have to cite this as "Massachusetts Institute of Technology (yyyy)" (I've checked, "MIT (yyyy)" is not acceptable). In any case, the only ways I can find to prevent BiBTeX mangling the name (to "Technology, M. I. (YYYY)" in the references list and "Technology (yyyy)" in the citation) are to do one of the following in my .bib file:

1a) author = {{Massachusetts Institute of Technology}},

1b) author = {\mbox{Massachusetts Institute of Technology}},

2) author = {Massachusetts Institute of Technology,\ },

However, 1a/b, prevent correct line breaking by hyperref as they create a single token, and 2, gives a reference list of "Massachusetts Institute of Technology, (yyyy)" instead of "Massachusetts Institute of Technology (yyyy)" (additional comma between name and year).

I can post a MWE if required, but hopefully the above description is enough to convey what's going on. I've been right through the BibTeX and natbib documentation, but I just can't find an answer to this!

share|improve this question

closed as too localized by lockstep, egreg, percusse, Paulo Cereda, Marco Daniel Jan 21 '12 at 18:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
A MWE with regard to case 1a) and incorrect line breaking would indeed be helpful. –  lockstep Jan 21 '12 at 17:29
    
I feel as though I'm going slightly insane - I've just tried to create a MWE, but I couldn't. And now I've gone back to my original document and that's working too. What have I spent the last 3 hours trying to work out!? Thanks for taking the time to read my OP. –  IainCunningham Jan 21 '12 at 17:47
    
Anyway, it works now. ;-) We'll probably close this question as "too localized". –  lockstep Jan 21 '12 at 17:49