Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am putting bibliography in my last frame. It seems that the command

\beamerdefaultoverlayspecification{<+->}

makes the article symbols look like book. You can see this by remarking this command in the following code:

\documentclass{beamer}

\usecolortheme{crane}

\beamerdefaultoverlayspecification{<+->}

\begin{document}
    \begin{frame}{For Further Reading}

  \begin{thebibliography}{10}

  \beamertemplatebookbibitems

  \bibitem{Author1990}
    A.~Author.
    \newblock {\em Handbook of Everything}.
    \newblock Some Press, 1990.

  \beamertemplatearticlebibitems

  \bibitem{Someone2000}
    S.~Someone.
    \newblock On this and that.
    \newblock {\em Journal of This and That}, 2(1):50--100,
    2000.
  \end{thebibliography}
\end{frame}
\end{document}

Just for curiosity I would like to know how to overcome this bug. However, I would actually like to show all bibliography items at once and not gradually in my presentation, which might resolve the problem. So my question is - how do I cancel the effect of \beamerdefaultoverlayspecification{<+->} for one specific frame?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

It is possible to change the overlay specification mid-document. Simply add \beamerdefaultoverlayspecification{} immediately before the frame that includes your bibliography.

To confine the changes to this frame and switch back to whatever overlay specification was valid before, you may write

\begingroup
\beamerdefaultoverlayspecification{}

<code for bibliography frame>

\endgroup
share|improve this answer
    
Thanks! it solves the problem. However, maybe I leave this topic open for someone to solve the bug? –  Elec Jan 22 '12 at 18:08
    
@Elec That's okay -- if another answer shows how to overcome the bug, you should accept it. Note, however, that your question is considered "answered" because of the positive score of my answer, so you could ask a (bug-specific) follow-up question after a few days if no other answer is added. –  lockstep Jan 22 '12 at 18:12
    
@Elec I don't see this as a bug since bibitem is interpreted as a regular item inside the beamer engine. If you don't want to use a group definition, you can put your bib. frame as the following: \beamerdefaultoverlayspecification{} bib frame \beamerdefaultoverlayspecification{<+->} so you suspend the default spec for a frame and go back to the initial state. Otherwise you have to supply [<+->] option for each environment such as itemize/enumerate. –  percusse Jan 22 '12 at 19:59
    
@Elec cnt'd... You can find the overlay spec. option on page 103 for bibitem which shows that these items are also overlay specification-aware. Hence the observed effect. Also changing the book symbol can be done as explained on the same page and that seems normal since you include \beamertemplatebookbibitems. –  percusse Jan 22 '12 at 20:11
add comment

For displaying bibliography items separately, specifying a separate overlay produces the desired result:

enter image description here

\documentclass{beamer}% http://ctan.org/pkg/beamer
\usecolortheme{crane}
%\beamerdefaultoverlayspecification{<+->}
\begin{document}
\begin{frame}{For Further Reading}
  \begin{thebibliography}{10}
  \beamertemplatebookbibitems
  \bibitem{Author1990}
    A.~Author.
    \newblock {\em Handbook of Everything}.
    \newblock Some Press, 1990.

  \beamertemplatearticlebibitems
  \visible<2->{\bibitem{Someone2000}
    S.~Someone.
    \newblock On this and that.
    \newblock {\em Journal of This and That}, 2(1):50--100,
    2000.}
  \end{thebibliography}
\end{frame}
\end{document}

I used \visible<2-> to make the item only visible from slide 2 onward.

share|improve this answer
    
I'm also not sure why the global (default) overlay specification causes the problem. –  Werner Jan 22 '12 at 19:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.