Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm writing a document with a5paper formatting (obtained through the geometry package). In particular this means that I have narrower margins.

I really like TikZ and especially todonotes. The problem is that the box is larger than the margin. To fix that, I used the option textwidth, and all went fine.

As a last thing, I'd like to be able to reduce the size of the text, so I can fit larger words in. The option textsize seems to be there just for this purpose: unfortunately it doesn't work for me.

Here is an example of code I tried

\documentclass{article}
\usepackage[textsize=tiny]{todonotes}
\begin{document}
  blah blah blah blah\todo{more grothendieck blah} whatever blah blah.
\end{document}

obtaining the following in the log file

/usr/local/texlive/2008/texmf-dist/tex/latex/todonotes/todonotes.sty:80: LaTeX 
Error: Unknown option `textsize' for package `todonotes'

I also tried to download the package from CTAN and to load it locally but I got the same message.

Am I doing something wrong? Should I be perhaps updating TeXlive or something?

share|improve this question
2  
Your example works fine for me, with MikTeX 2.9 (beta), so yes, try updating TeXLive. –  Torbjørn T. Oct 17 '10 at 10:31
    
According to the documentation textsize was added with version 0.7.6 of todonotes –  Lev Bishop Oct 17 '10 at 15:18
1  
@Torbjorn: Could you please post that as an answer, so that it can be accepted. (Works fine with TeX Live 2009 and 2010.) –  Caramdir Oct 17 '10 at 16:58
    
I can't believe I still have texlive 2008! I'll proceed with an update immediately. –  slackenerny Oct 17 '10 at 23:17
    
@slackerny, I am not sure if I'm right, but I think it would be better to write more informative titles when posting a question, for example: 'Problem with the textsize option in todonotes' or similar. –  Vladimir Nov 11 '11 at 8:44
add comment

2 Answers

up vote 2 down vote accepted

Your example works fine with MikTeX 2.9 beta and TeXLive 2009/2010 (ref. Caramdirs comment), so an update of TeXLive should do the trick.

share|improve this answer
    
Yep, the trick worked! Thanks. –  slackenerny Oct 18 '10 at 2:22
    
Maybe redundant but let me add that I tried it with TexLive 2011 (on Ubuntu 11.10) and it also works. –  Vladimir Nov 11 '11 at 8:50
add comment

From reading the documentation, it looks like you want to use the option [size=\tiny].

share|improve this answer
    
Sure, but doesn't this work just for the single \todo command and not globally as an option for the whole package? I guess I could always write a \newcommand to include that option. It's just a shame that this textsize doesn't work. –  slackenerny Oct 17 '10 at 10:05
    
@slackenerny: Ah yes, you are correct. –  TH. Oct 17 '10 at 10:51
    
@TH: anyway, I appreciated the RTFM answer, I should be doing it more often. –  slackenerny Oct 18 '10 at 0:33
    
@slackenerny: And I should have read it more carefully. =) –  TH. Oct 18 '10 at 7:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.