Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I tried several times to play with XeLaTeX (being used to "classical" LaTeX) but since I installed MacTeX 2011 and updated it with TeX Live Utility, I got that kind message :

(/usr/local/texlive/2011/texmf-dist/tex/latex/l3packages/xparse/xparse.sty
/usr/local/texlive/2011/texmf-dist/tex/latex/l3packages/xparse/xparse.sty:57: U
ndefined control sequence.
<argument> \ExplFileName 

l.57 ...e}{\ExplFileVersion}{\ExplFileDescription}

If I continuously press "Return", I got a lot of error messages linked to Unicode font scripts, for instance :

/usr/local/texlive/2011/texmf-dist/tex/latex/fontspec/fontspec.sty:1909: Undefi
ned control sequence.
l.1909 \newfontlanguage{Efik}{EFI}\newfontlanguage
                                              {Greek}{ELL}

I seems there is a problem between version of xparse, fontspec etc. But it occurs even after re-installing Tex Live and updating only one package not linked to xelatex or fonts. The log file is quite long with all these errors (about 4200 lines).

Could it be caused by the scripts run by tlmgr after updating a package?

Edit:Sorry for mistake about "answer".

Here is a link to the log file : http://dl.dropbox.com/u/6420461/xelatex3.log

share|improve this question
1  
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. –  qubyte Jan 27 '12 at 10:02
1  
Your version of l3kernel does not match that for l3packages. Try at the Terminal sudo tlmgr update l3kernel and sudo tlmgr update l3packages. –  Joseph Wright Jan 27 '12 at 10:07
    
MacTeX also installs the TeX Live Utility. If you launch that it should tell you if anything else is out of date and help you to update everything. This is also a neat way of finding out about new packages. –  qubyte Jan 27 '12 at 10:25
    
(TL2011) I update this morning all the packages (Update all packages) with TeX Live Utility and my codes compile very well. Perhaps you can give a minimal working example. –  Alain Matthes Jan 27 '12 at 11:07
    
I finally understood why update broke a working installation for xetex : the Tex Live Utility preferences "remove packages to match the server when updating" was not checked. So there was a conflict between expl3 and l3kernel. Thanks ! –  user11208 Jan 28 '12 at 15:45
show 1 more comment

1 Answer

The log is exactly what I expected to see: a partly updated system. You need to remove the older expl3 bundle and install l3kernel. You may also need ot remove the older xpackage bundle and replace with the newer l3packages. From the Terminal, sudo tlmgr update --self --all will do this.

share|improve this answer
    
I ran into the same problem, and despite tlmgr not finding any updates available, the problem persists. Exact same causes, same error messages... The problem seems to be with sparse, which the tex live utility tells me is up to date –  Timothée Poisot Mar 16 '12 at 18:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.