TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The code below gives nice slides with a navigation bar on top that leads to the different sections (I have no subsections) in the presentation. However, below the navigation bar there is a second bar (grey) without any content that I would like to get rid off because it just takes up space. Does anyone know how to do that? Removing that bar would result in the "perfect" presentation for me.



\title[Short title]{\textsc{{Long title 1}}}   
\author{Aut Hor} 
\institute[Short Ins]{Ins}


\frame{\frametitle{FIRST FRAME} 
    \item item 1 
    \item item 2

\frame{\frametitle{SECOND FRAME} 
    \item item 4
    \item item 5

share|improve this question
Welcome to TeX.sx! A tip: If you indent lines by 4 spaces, they'll be marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). – Seamus Jan 31 '12 at 10:55

As lockstep explained, the Szeged theme does:

  1. applies compress option
  2. loads miniframes outer theme with theme options footline=instituteline and subsection=true
  3. sets a separation line color which is suppressed with \usecolortheme{Seagull}.

Knowing that you can just apply compress option and change options for miniframes with next preamble:

\useoutertheme[subsection=false, footline=institutetitle]{miniframes}

Stefan Kottwitz provides a better solution: Szeged theme loads miniframes outer theme with subsection=true which clashes with a later call to \useoutertheme[subsection=false]{miniframes}. This clash is avoided if subsection=false option is set before loading themes:

\usetheme{Szeged} % implicitely loads miniframes
\section{A section}
\subsection{A subsection}
share|improve this answer
This is a superior method. Sadly, beamer doesn't seem to allow first loading a "complete" theme like Szeged and only then disabling some of its underlying options. – lockstep Jan 31 '12 at 17:36
@lockstep: Yes, it seems so. In any case, Stefan Kottwitz provides a better solution in my following question. – Ignasi Jan 31 '12 at 17:53
I tried all of those solutions and they all work. Thank you very much! One final question. Is it possible to get rid of the thin white line (probably it is only white in seagull color scheme) that separates the navigation bar from the top border of the slide? – Paul Feb 1 '12 at 10:01
If this white line first appears on second frame, it's a compatibility problem between older versions of pgf and beamer. Update both packages and the line will disappear. – Ignasi Feb 1 '12 at 10:20
Thank you Ignasi. I discovered that the white line only appears in Sumatrapdf not in Adobe reader.. so problem solved.. – Paul Feb 1 '12 at 18:22

The Szeged theme uses the miniframes outer theme which declares the beamer@theme@subsection conditional and sets it to true. This in turn adds color boxes to display the \subsections. You may remove the boxes by adding the following after \usetheme{Szeged}:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.