TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I try to copy and paste in a LyX document I am editing and it says that the command (paste) is disabled. This happens with anything, be it normal text, figures or formulae. I am working on a 64 bit PC with Windows 7 and using Lyx 2.0. I checked the document settings in short cuts and they are set. This is so frustrating. Can anyone help me please?

share|improve this question
    
This may be because Ctrl+V is bound to some other command. Can you paste by using the regular Edit menu? – Werner Feb 2 '12 at 7:17
1  
I suppose that you have a write protected document. That happens for all example documents of the LyX documentation. – Herbert Feb 2 '12 at 7:36
    
It's 2016 and this bug in LyX still isn't fixed. Not that copy&paste is an essential feature for a text processor *sigh*. Anyhow, restarting LyX makes the issue go away for a while, in my case. – DerManu Mar 6 at 15:34

I have the same problem when I use LyX 2.0.2 on 64 bit PC with Windows 7. It happen sometimes, and can be resolved by restarting the LyX. I also use LyX on other OS, e.g., 32 bit Windows 7 and Ubuntu, and never encounter this problem there. Maybe this is a compatibility issue on the 64 bit Windows.

share|improve this answer
    
Just save everything, close it and open it again (restart as Shoreming mentioned). It'll work hopefully. – user14013 Apr 27 '12 at 10:55
    
Had the same problem - restarting the computer solved it. – user16277 Jul 4 '12 at 20:00
    
Problem still exists in LyX 2.0.6 (Win7 x64). Restarting LyX still solve the problem. – Juve Dec 3 '13 at 14:34

While I still do not know the culprit of this problem, I think I have found a workaround.

Even when paste is disabled, I found paste recent is still active, so I just binded ctrl+v to paste 0 instead of paste. It seems to be working well so far.

-- Edited --

I spoke too early. It works within LyX, but paste recent does not capture texts copied outside of LyX.

share|improve this answer
    
Did you manage to fix it? I've also run into this problem tex.stackexchange.com/questions/277997/… – Sebi Nov 12 '15 at 20:35
    
Except my answer, unfortunately no. But in my case restarting LyX fixes the problem so it is not critical. – joon Nov 12 '15 at 21:30

Same problem in LyX 2.1.4 on Windows 7. I remapped ctrl+v to paste 0 and ctrl+shift+v to paste

The first allows me to paste within LyX keeping all the formatting etc. The second gives me access to the clipboard. This seems to work well. I'm not sure what causes this issue though.

share|improve this answer
    
Welcome to TeX.SX! Your question won't be seen by many people here, so it would be best to repost it as a fresh question. Follow-up questions like this are more than welcome! Please use the "Ask Question" link for your new question; there you can link to this question to provide the background. – Seamus Feb 11 at 17:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.