Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am writing a long document so I am making use of sub-documents and inserting them with \include.

The problem I am facing is that as the \bibliography{} line is on the main .tex file the sub-documents are not able to 'see' what is in the bibtex file, hence when I run the auto-completion function while editing the sub-document I cannot see the options for citing.

If I try the auto-completion function while editing the main.tex file I am able to see all the different options for citing.

How can I tell the sub-document to see that bibtex file too?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

After some time I found the trick:

You just need to add the line

%\bibliography{bibtexfile}

as a comment and vim will know where to look for the auto-completion options

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.