Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the %&format magic line in a plain TeX file. On older versions of TeX the result produces the expected results. On TeXLive 2009 (under Gentoo), however, this line has no effect. When I use 'tex -fmt format.fmt file.tex' the expected font substitutions nevertheless work. Has the magic file feature to be enabled in some config file? Many thanks.

share|improve this question

2 Answers 2

Thanks for the speedy reply. In Gentoo the file is /etc/texmf/web2c/texmf.cnf. In there, parse_first_line was set true by default, but parse_first_line.tex was set to false. Changing to true ('t') fixed the problem. Great help!

share|improve this answer
4  
You should add that as a comment rather than an answer. –  TH. Oct 20 '10 at 23:01
    
@TH: I don't think he has the rep to do that yet. –  SamB Nov 30 '10 at 3:09
    
By the way, Michael, it is probably a good idea to associate an openid with your account in case you lose the cookie. (Assuming, of course, that you have not already lost it.) –  SamB Nov 30 '10 at 3:14

I don't know about Gentoo, but this is controlled by the parse_first_line option. For me, it lives in /.../texlive/2010/texmf/web2c/texmf.cnf. That said, changes should go in /.../texlive/2010/texmf.cnf:

parse_first_line = t
share|improve this answer
1  
or use command line option [-no]-parse-first-line –  Martin Heller Oct 20 '10 at 22:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.