Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The code

\documentclass{article}
%\usepackage{fontspec}
\usepackage[condensed,math]{anttor}
\usepackage[T1]{fontenc}
\begin{document}
0123$0123$
\end{document}

run well when I compiled with pdflatex; while

\documentclass{article}
\usepackage{fontspec}
\usepackage[condensed,math]{anttor}
\usepackage[T1]{fontenc}
\begin{document}
0123$0123$
\end{document}

not so well with xelatex. The numbers in math mode is typesetting in CM fonts. enter image description here

share|improve this question
    
Have you tried passing the option no-math to fontspec? –  Mico Feb 6 '12 at 8:43
    
I've deleted my answer since @egreg's answer (which expands on Mico's comment) is a better one. –  Alan Munn Feb 6 '12 at 15:44
add comment

1 Answer

You can use the math fonts coming with Antykwa Torunska also with XeLaTeX:

\documentclass{article}
\usepackage[condensed,math]{anttor}
\usepackage[no-math]{fontspec}
\setmainfont{Antykwa Torunska Condensed}

\begin{document}
0123$0123\sum_{i=1}^n \sin n\phi$
\end{document}

The important thing is to load anttor before fontspec, to which the no-math option should be given.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.