Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

At my class I am supposed to write a report where the chapter headings are always in uppercase, but have to printed in sentence case in the table of contents. For regular chapters I have achieved this by using

\chapter*{EXAMPLE}
\addcontentsline{toc}{chapter}{Example}

but I cannot figure out how to achieve the same result for the bibliography. I have used

\renewcommand\bibname{REFERENCES}
\addcontentsline{toc}{chapter}{References}

but then the bibliography heading is printed twice in the table of contents. Is there any way to force the table of contents to print the references heading once?

Here is the preamble for the document

\documentclass[a4paper, 12pt]{report} 
\usepackage{apacite}
\usepackage{graphicx}
\usepackage{anysize}
\usepackage{setspace}
\usepackage{lscape}
\usepackage{parskip}
\usepackage{float}
\usepackage[utf8]{inputenc}
\usepackage{url}
\usepackage{times} 
share|improve this question
    
Welcome to TeX.SX! With the standard classes the bibliography is not automatically added to the table of contents, so you should at least provide information about the class you're using and relevant parts of the preamble. –  egreg Feb 6 '12 at 15:56
    
I am using the report class for my document so the bibliography is added automatically to the toc. –  Ilya Shmorgun Feb 6 '12 at 16:02
3  
No, the report class doesn't do that; so the addition is due to some package you're loading. –  egreg Feb 6 '12 at 16:08
1  
I believe that a MWE would make your situation and desires clear. –  tohecz Feb 6 '12 at 16:18
    
Here is the preamble for the document \documentclass[a4paper, 12pt]{report} % Packages \usepackage{apacite} \usepackage{graphicx} \usepackage{anysize} \usepackage{setspace} \usepackage{lscape} \usepackage{parskip} \usepackage{float} \usepackage[utf8]{inputenc} \usepackage{url} \usepackage{times} –  Ilya Shmorgun Feb 6 '12 at 18:04

2 Answers 2

up vote 3 down vote accepted

Use your code, but call

\usepackage[notocbib]{apacite}

Remember, though, to issue

\cleardoublepage
\renewcommand\bibname{REFERENCES}
\addcontentsline{toc}{chapter}{References}

in order to be sure that the page reference is correct.

share|improve this answer
    
This worked. Thank you very much! –  Ilya Shmorgun Feb 7 '12 at 9:27

The package apacite provides their own bibliography environment. Therefore, the package offers some options. Related to your questions the important options are:

  • tocbib
  • notocbib

The manual explains:

tocbib

This puts the bibliography in the table of contents, even if it is unnumbered, provided of course that a table of contents is requested in the document (by \tableofcontents). This is the default.

notocbib

This does not put the bibliography in the table of contents if it is an unnumbered section or chapter. If it’s numbered, it is always in the table of contents.

So you have to set the option notocbib.

share|improve this answer
    
Thank you very much for your help! –  Ilya Shmorgun Feb 7 '12 at 9:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.