Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have to create a camera-ready paper. This means that I have to follow specific guidelines regarding text size. Of course I am using geometry package to specify the text area but I am running in a problem. I checked if text was typeset correctly, using showframe option and I found out that it is typeset outside of the text area. Not only horizontally, for which I don't really care, as I am getting an hbox warning, but vertically too. I mean that on some cases letters on the last line like "p", "g" etc are being typeset below the frame.

How can I prevent TeX from typesetting text outside the specified area? Should I tackle this problem case by case starting from the beginning? Would tweaking some TeX variables (constants is a proper name?) would help? If that is the case, which variables should I change?

Edit

Here is an example. The lines are drawn by the geometry package. I'll try to make a mwe and I will upload it.

Example

share|improve this question
1  
Could you post a minimal example? –  Michael Palmer Feb 7 '12 at 21:16
    
Would it be possible to compose a fully compilable MWE that illustrates the problem including the \documentclass and the appropriate packages. –  Peter Grill Feb 7 '12 at 21:16
    
Please be a bit more specific as to the note that "[text] is typeset outside the text area." Are there words that TeX fails to hyphenate? If it's a matter of the last line of text on a page exceeding the allowable textblock, you can always reduce the \textheight variable (very) slightly so that LaTeX will set one less line of text per page. –  Mico Feb 7 '12 at 21:21
    
Are there no margins between the text and the target camera frame? –  Brent.Longborough Feb 7 '12 at 21:36
    
@Brent.Longborough Probably there are, but I don't know for sure. The instructions (which were obviously written with Word in mind) are specific that absolutely no text must be outside the allowed area. –  pmav99 Feb 7 '12 at 21:41

2 Answers 2

up vote 7 down vote accepted

The parameter \maxdepth states the maximum depth allowed for the last line of the text block (TeXbook, page 113); so setting

\setlength{\maxdepth}{0pt}

in the preamble should do the trick.

share|improve this answer

Just to amplify egreg's answer and to present a MWE for the curious. The \maxdepth value determines the maximum depth of a page. If a page exceeds this value, the page is moved up in a process that is very similar to the adjustment of a reference point in a vbox when \boxmaxdepth is taken into account. To see this adjust the rule height in the MWE gradually from say 5pt-12.4pt and observe the output. Uncomment the \setlength\maxdepth to correct the issue.

\documentclass[11pt]{article}
\usepackage[showframe]{geometry}
\usepackage{lipsum}
%\setlength\maxdepth{0pt}

\begin{document}
\rule{13pt}{12.4pt}

\lipsum

\the\maxdepth
\end{document}

You should see this at the left corner of the first page,

enter image description here

share|improve this answer
    
Ευχαριστώ! - Thank you! –  pmav99 Feb 8 '12 at 18:19
    
\textgreek{parakalw!}. –  Yiannis Lazarides Feb 8 '12 at 18:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.