Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I already tried Adobe Acrobat, Adobe Acrobat Reader and Sumatra PDF but all doesn't work..

The first time if I use latex -> pdf output profile it works. But if something is changed I still get the same PDF. If I then delete the PDF I get in Adobe Acrobat

this file cannot be found

Settings:

Path of executable:
C:\PROGRAM FILES (X86)\ADOBE\ACROBAT 10.0\ACROBAT\ACROBAT.EXE

Command line command:

"%bm.pdf"

Forward search the same.

Also tried:

DDE command:
[DocOpen("%bm.pdf")][FileOpen("%bm.pdf")]

with server:

acroviewA10, topic: control

(according to TexnicCenter and Adobe Reader 10 / X)

Who can help?

UPDATE: It seems that the miketex setting: install packages on the fly was causing the problem. I changed the setting from install packages on fly from "ask me first" to "YES". Now the pdf's are produced. The pdf reader opens and closes really fast however..but I can make pdfs! (took me several hours to fix this..)..

share|improve this question
    
Have you checked the default pdf viewer setting or the configuration settings of TexnicCenter? –  azetina Feb 8 '12 at 19:19
3  
We'd like to keep answers separate from questions, so you should write a separate answer instead of editing your answer into the question. Self-answers are perfectly admissible, and a well-written answer may earn you additional reputation. –  Werner Feb 8 '12 at 20:50
add comment

3 Answers

Updated (Sept 15,2013):

I use Adobe Reader 11 (free version) and my settings are as follows. The red rectangles are used to highlight the important parts. If you use version 10, simply change the number 11 to 10.

enter image description here

Note: Since I have added Adobe Reader 11 path to my system variable, I don't need to specify the full path in "Path of executable" section on the dialog box above.

share|improve this answer
    
Thanks for the help. I already had most of these settings. I did have the full path. –  Lennart Feb 8 '12 at 20:36
    
For Adobe Acrobat X (the editor, not the reader) I had to use AcroViewA10 for the server name. See this blog post. –  Florian Brucker Oct 31 '13 at 12:04
1  
Let me point to the original Adobe blog entry: Big Changes in the DDE Naming Convention for Acrobat X, where you also can see the differentiation betwenn reader and editor. –  Speravir Mar 20 at 21:51
add comment

In Adobe Reader and Acrobat (the editor) X and XI the protected mode is in Security(Enhanced) and not on the General: Adobe Acrobat: Protected View (Windows only).

You need to disable that.

share|improve this answer
add comment

Adobe Reader X has a security feature called Protected Mode. By default, Protected Mode is enabled at startup. While I do not understand the details, if protected mode is enabled, TeXnikCenter's build profiles are not able to interact 100% successfully with Adobe Reader X.

So along with the build profile information in @Garbage Collector's answer, you should open Adobe Reader X and go to Edit -> Preferences. Go to a category called General at the left. Near the bottom there is a checkbox Enable Protected Mode at startup. Uncheck this. (And again, follow the changes in Garbage Collector's answer.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.