Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to use dot2texi package with Texmaker on a Mac, and I am aware that I need to enable shell escape in order to let TeX Live process using external packages. So I edit the commands in Texmaker to the following:

"/usr/texbin/latex" -interaction=nonstopmode --shell-escape %.tex (for LaTeX)

"/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode --shell-escape %.tex (for PdfLaTeX)

However, when I try outputting the following TeX file, I keep getting warning that says "shell escape not enabled", and consequently the dot2texi doesn't work.

\documentclass[10pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}

% dot graphs
\usepackage{dot2texi}
\usepackage{tikz}
\usetikzlibrary{shapes,arrows}

\author{Anonymous}
\title{Dot graphs in \LaTeX}

\begin{document}

\maketitle

\begin{dot2tex}[dot,options=-tmath --autosize --cache]
digraph G 
{
   node [shape="circle"]; 
   a_1 -> a_2 -> a_3 -> a_4 -> a_1;
}
\end{dot2tex}}

\end{document}

Not sure what else I need to do here. Any suggestion would be extremely welcome.

share|improve this question

migrated from stackoverflow.com Feb 12 '12 at 3:36

This question came from our site for professional and enthusiast programmers.

closed as too localized by egreg, Andrey Vihrov, Torbjørn T., lockstep, Paulo Cereda Mar 4 '12 at 0:17

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
If I do that, I get that the shell escape is enabled. Check that the called compiler is one of the two. –  egreg Feb 12 '12 at 10:11
2  
Did you try -shell-escape? (note that it uses one dash) –  adn Feb 12 '12 at 14:03

Browse other questions tagged or ask your own question.